aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.8/0021-GPIO-MIPS-add-gpio-driver-for-falcon-SoC.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-03-15 14:39:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-03-15 14:39:51 +0000
commit84da5668735a12ef1a36eeb6777c37cd0de63ef9 (patch)
tree8417e7b50ec23e10ee0678ad5b4f032260cc6b2a /target/linux/lantiq/patches-3.8/0021-GPIO-MIPS-add-gpio-driver-for-falcon-SoC.patch
parent257aff3780d895c15f710ee10edeeb9c04e97ed1 (diff)
downloadmaster-187ad058-84da5668735a12ef1a36eeb6777c37cd0de63ef9.tar.gz
master-187ad058-84da5668735a12ef1a36eeb6777c37cd0de63ef9.tar.bz2
master-187ad058-84da5668735a12ef1a36eeb6777c37cd0de63ef9.zip
kernel: update linux 3.8 to 3.8.3
Also refresh the related generic/platform patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36039 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/patches-3.8/0021-GPIO-MIPS-add-gpio-driver-for-falcon-SoC.patch')
-rw-r--r--target/linux/lantiq/patches-3.8/0021-GPIO-MIPS-add-gpio-driver-for-falcon-SoC.patch12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/lantiq/patches-3.8/0021-GPIO-MIPS-add-gpio-driver-for-falcon-SoC.patch b/target/linux/lantiq/patches-3.8/0021-GPIO-MIPS-add-gpio-driver-for-falcon-SoC.patch
index a6d3259ec9..00ad437d1a 100644
--- a/target/linux/lantiq/patches-3.8/0021-GPIO-MIPS-add-gpio-driver-for-falcon-SoC.patch
+++ b/target/linux/lantiq/patches-3.8/0021-GPIO-MIPS-add-gpio-driver-for-falcon-SoC.patch
@@ -16,8 +16,6 @@ Cc: linux-kernel@vger.kernel.org
3 files changed, 355 insertions(+)
create mode 100644 drivers/gpio/gpio-falcon.c
-diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
-index 682de75..e8d84fa 100644
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -133,6 +133,11 @@ config GPIO_EP93XX
@@ -32,11 +30,9 @@ index 682de75..e8d84fa 100644
config GPIO_MM_LANTIQ
bool "Lantiq Memory mapped GPIOs"
depends on LANTIQ && SOC_XWAY
-diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile
-index c5aebd0..9bdbb91 100644
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
-@@ -24,6 +24,7 @@ obj-$(CONFIG_GPIO_DA9055) += gpio-da9055.o
+@@ -24,6 +24,7 @@ obj-$(CONFIG_GPIO_DA9055) += gpio-da9055
obj-$(CONFIG_ARCH_DAVINCI) += gpio-davinci.o
obj-$(CONFIG_GPIO_EM) += gpio-em.o
obj-$(CONFIG_GPIO_EP93XX) += gpio-ep93xx.o
@@ -44,9 +40,6 @@ index c5aebd0..9bdbb91 100644
obj-$(CONFIG_GPIO_GE_FPGA) += gpio-ge.o
obj-$(CONFIG_GPIO_ICH) += gpio-ich.o
obj-$(CONFIG_GPIO_IT8761E) += gpio-it8761e.o
-diff --git a/drivers/gpio/gpio-falcon.c b/drivers/gpio/gpio-falcon.c
-new file mode 100644
-index 0000000..ae8b55d
--- /dev/null
+++ b/drivers/gpio/gpio-falcon.c
@@ -0,0 +1,349 @@
@@ -399,6 +392,3 @@ index 0000000..ae8b55d
+}
+
+subsys_initcall(falcon_gpio_init);
---
-1.7.10.4
-