aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.7/0301-gptu.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-01-28 17:44:20 +0000
committerJohn Crispin <blogic@openwrt.org>2013-01-28 17:44:20 +0000
commitd9ec668adbd6d455932b0a56a2eb7c4dabfa0770 (patch)
treec55fc9e7d219aea4cc04c9be3b2e663b5481ed65 /target/linux/lantiq/patches-3.7/0301-gptu.patch
parent1c3c233117fc06f3a827f2afa2ebb787bf4356c4 (diff)
downloadmaster-187ad058-d9ec668adbd6d455932b0a56a2eb7c4dabfa0770.tar.gz
master-187ad058-d9ec668adbd6d455932b0a56a2eb7c4dabfa0770.tar.bz2
master-187ad058-d9ec668adbd6d455932b0a56a2eb7c4dabfa0770.zip
[lantiq] refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35355 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/patches-3.7/0301-gptu.patch')
-rw-r--r--target/linux/lantiq/patches-3.7/0301-gptu.patch18
1 files changed, 6 insertions, 12 deletions
diff --git a/target/linux/lantiq/patches-3.7/0301-gptu.patch b/target/linux/lantiq/patches-3.7/0301-gptu.patch
index 33fb0fb86c..77fcb68f45 100644
--- a/target/linux/lantiq/patches-3.7/0301-gptu.patch
+++ b/target/linux/lantiq/patches-3.7/0301-gptu.patch
@@ -1,7 +1,5 @@
-Index: linux-3.7.1/arch/mips/lantiq/xway/timer.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.1/arch/mips/lantiq/xway/timer.c 2012-12-18 22:24:36.133175326 +0100
+--- /dev/null
++++ b/arch/mips/lantiq/xway/timer.c
@@ -0,0 +1,841 @@
+#include <linux/kernel.h>
+#include <linux/module.h>
@@ -844,10 +842,8 @@ Index: linux-3.7.1/arch/mips/lantiq/xway/timer.c
+
+module_init(lq_gptu_init);
+module_exit(lq_gptu_exit);
-Index: linux-3.7.1/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.1/arch/mips/include/asm/mach-lantiq/lantiq_timer.h 2012-12-18 20:47:56.625037132 +0100
+--- /dev/null
++++ b/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
@@ -0,0 +1,155 @@
+#ifndef __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
+#define __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
@@ -1004,10 +1000,8 @@ Index: linux-3.7.1/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
+ u32 reload, unsigned long arg1, unsigned long arg2);
+
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
-Index: linux-3.7.1/arch/mips/lantiq/xway/Makefile
-===================================================================
---- linux-3.7.1.orig/arch/mips/lantiq/xway/Makefile 2012-12-18 20:48:40.717038183 +0100
-+++ linux-3.7.1/arch/mips/lantiq/xway/Makefile 2012-12-18 22:24:48.965175632 +0100
+--- a/arch/mips/lantiq/xway/Makefile
++++ b/arch/mips/lantiq/xway/Makefile
@@ -1,3 +1,3 @@
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o