aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-20 14:41:54 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-20 14:41:54 +0000
commitfdbc285bc3ea3969e3e68213266940469a08eb19 (patch)
tree689608c958602170f086d0a050e278d9875019ab /target/linux/lantiq/image
parent49ca717b2f9f68c6892876f03bc5191a82604b9a (diff)
downloadmaster-187ad058-fdbc285bc3ea3969e3e68213266940469a08eb19.tar.gz
master-187ad058-fdbc285bc3ea3969e3e68213266940469a08eb19.tar.bz2
master-187ad058-fdbc285bc3ea3969e3e68213266940469a08eb19.zip
lantiq: use upstream mechanism to append device tree file
Instead of using our patch-dtb program just place the device tree behind the kernel binary and then let the in kernel mechanism fetch it. This also adds support for having the device tree file in the boot loader. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49050 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 882fba80f8..c3cb48afdf 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -32,8 +32,8 @@ endef
define PatchKernelLzma
cp $(KDIR)/vmlinux$(2) $(KDIR)/vmlinux$(2)-$(1)
$(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(KDIR)/$(1).dtb ../dts/$(1).dts
- $(STAGING_DIR_HOST)/bin/patch-dtb $(KDIR)/vmlinux$(2)-$(1) $(KDIR)/$(1).dtb
- $(call CompressLzma,$(KDIR)/vmlinux$(2)-$(1),$(KDIR)/vmlinux$(2)-$(1).lzma)
+ cat $(KDIR)/vmlinux$(2)-$(1) $(KDIR)/$(1).dtb > $(KDIR)/vmlinux$(2)-$(1).tmp
+ $(call CompressLzma,$(KDIR)/vmlinux$(2)-$(1).tmp,$(KDIR)/vmlinux$(2)-$(1).lzma)
endef
define MkBrnImage