aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-06-08 17:57:55 +0000
committerJohn Crispin <blogic@openwrt.org>2011-06-08 17:57:55 +0000
commite558a1dec9373aca5c3cc204174cb365c84f2af2 (patch)
treeffd7da1e43d27e2a2244b1a7c54a3dd1307e6057 /target/linux/lantiq/image
parent3c9611d54fec763c83f060574b31e417b1f0e66b (diff)
downloadmaster-187ad058-e558a1dec9373aca5c3cc204174cb365c84f2af2.tar.gz
master-187ad058-e558a1dec9373aca5c3cc204174cb365c84f2af2.tar.bz2
master-187ad058-e558a1dec9373aca5c3cc204174cb365c84f2af2.zip
[lantiq]
* fixes spi flash for ar9 * adds limited support for netgear dgn3500 (enough for others to start working with) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27137 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index e73ee1936d..0e62ce5660 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -136,6 +136,14 @@ define Image/Build/Profile/ARV752DPW22
$(call Image/Build/$(1),$(1),ARV752DPW22)
endef
+define Image/BuildKernel/Profile/DGN3500B
+ $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/DGN3500B
+ $(call Image/Build/$(1),$(1),DGN3500B)
+endef
+
define Image/BuildKernel/Profile/Generic
$(call Image/BuildKernel/Template,EASY4010,$(xway_cmdline))
$(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
@@ -149,6 +157,7 @@ define Image/BuildKernel/Profile/Generic
$(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
$(call Image/BuildKernel/Template,NONE)
endef
@@ -165,6 +174,7 @@ define Image/Build/Profile/Generic
$(call Image/Build/$(1),$(1),ARV7518PW)
$(call Image/Build/$(1),$(1),ARV752DPW)
$(call Image/Build/$(1),$(1),ARV752DPW22)
+ $(call Image/Build/$(1),$(1),DGN3500B)
$(call Image/Build/$(1),$(1),NONE)
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
endef