aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-07-07 20:20:51 +0000
committerJohn Crispin <blogic@openwrt.org>2011-07-07 20:20:51 +0000
commit5b126c6b93d2b469fd1fa548952fc606cd287ae1 (patch)
treeccb1e071ef949174915846f4e986fe3acdc819ca /target/linux/lantiq/image
parentae8aa68eebb51f416cad14e8075eae827880f735 (diff)
downloadmaster-187ad058-5b126c6b93d2b469fd1fa548952fc606cd287ae1.tar.gz
master-187ad058-5b126c6b93d2b469fd1fa548952fc606cd287ae1.tar.bz2
master-187ad058-5b126c6b93d2b469fd1fa548952fc606cd287ae1.zip
fix generation of falcon images for profiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27550 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index f0c06fd94e..473094655e 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -202,6 +202,22 @@ endef
endif
ifeq ($(CONFIG_TARGET_lantiq_falcon)$(CONFIG_TARGET_lantiq_falcon_stable),y)
+define Image/BuildKernel/Profile/EASY98000
+ $(call Image/BuildKernel/Template,EASY98000,$(falcon_cmdline))
+endef
+
+define Image/Build/Profile/EASY98000
+ $(call Image/Build/$(1),$(1),EASY98000)
+endef
+
+define Image/BuildKernel/Profile/EASY98020
+ $(call Image/BuildKernel/Template,EASY98020,$(falcon_cmdline))
+endef
+
+define Image/Build/Profile/EASY98020
+ $(call Image/Build/$(1),$(1),EASY98020)
+endef
+
define Image/BuildKernel/Profile/Generic
$(call Image/BuildKernel/Template,EASY98000,$(falcon_cmdline))
$(call Image/BuildKernel/Template,EASY98020,$(falcon_cmdline))