aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-02-04 22:49:52 +0000
committerJohn Crispin <blogic@openwrt.org>2011-02-04 22:49:52 +0000
commit21c6d893738cf7196e8c5827fb9901656012ba0c (patch)
treecbb02e2f8d21f6239b265e0d70df62408dc4ba20 /target/linux/lantiq/image
parent5bd97265a1b087d090137104f094a99683a3d8e3 (diff)
downloadmaster-187ad058-21c6d893738cf7196e8c5827fb9901656012ba0c.tar.gz
master-187ad058-21c6d893738cf7196e8c5827fb9901656012ba0c.tar.bz2
master-187ad058-21c6d893738cf7196e8c5827fb9901656012ba0c.zip
[lantiq]
* adds ath5k platform support * adds several new profiles git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25367 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile36
1 files changed, 34 insertions, 2 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index b580c99e2d..cc5d696d83 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -54,7 +54,7 @@ define Image/BuildKernel/Template
$(CP) $(KDIR)/uImage-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage
endef
-ifeq ($(CONFIG_SOC_LANTIQ_XWAY),y)
+ifeq ($(CONFIG_TARGET_lantiq_xway),y)
define Image/BuildKernel/Profile/EASY50712
$(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
endef
@@ -71,6 +71,38 @@ define Image/Build/Profile/EASY50812
$(call Image/Build/$(1),$(1),EASY50812)
endef
+define Image/BuildKernel/Profile/ARV4518PW
+ $(call Image/BuildKernel/Template,ARV4518PW,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/ARV4518PW
+ $(call Image/Build/$(1),$(1),ARV4518PW)
+endef
+
+define Image/BuildKernel/Profile/ARV4520PW
+ $(call Image/BuildKernel/Template,ARV4520PW,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/ARV4520PW
+ $(call Image/Build/$(1),$(1),ARV4520PW)
+endef
+
+define Image/BuildKernel/Profile/ARV4525PW
+ $(call Image/BuildKernel/Template,ARV4525PW,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/ARV4525PW
+ $(call Image/Build/$(1),$(1),ARV4525PW)
+endef
+
+define Image/BuildKernel/Profile/ARV452CPW
+ $(call Image/BuildKernel/Template,ARV452CPW,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/ARV452CPW
+ $(call Image/Build/$(1),$(1),ARV452CPW)
+endef
+
define Image/BuildKernel/Profile/ARV752DPW22
$(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
endef
@@ -111,7 +143,7 @@ define Image/Build/Profile/Generic
endef
endif
-ifeq ($(CONFIG_SOC_LANTIQ_FALCON),y)
+ifeq ($(CONFIG_TARGET_lantiq_falcon),y)
define Image/BuildKernel
$(call Image/BuildKernel/Template,EASY98000,$(falcon_cmdline))
$(call Image/BuildKernel/Template,NONE)