aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-05-10 23:03:43 +0000
committerLuka Perkov <luka@openwrt.org>2016-06-19 19:36:02 +0200
commitaa16759d3d838c7f0d1b02e5a8aa9f665468871d (patch)
treebe11f88170a4e716cf44d20bd54828902269d49d /target/linux/kirkwood
parent657b605b3dff03e5b57196829d8efa69d1459376 (diff)
downloadmaster-187ad058-aa16759d3d838c7f0d1b02e5a8aa9f665468871d.tar.gz
master-187ad058-aa16759d3d838c7f0d1b02e5a8aa9f665468871d.tar.bz2
master-187ad058-aa16759d3d838c7f0d1b02e5a8aa9f665468871d.zip
krikwood: Make Iconnect image use new ubi format style
To flash first time follow instructions in commit: "kirkwood/dockstar: use ubi(kernel, squashfs, ubifs) images" Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@neratec.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49370 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/base-files/lib/upgrade/platform.sh6
-rw-r--r--target/linux/kirkwood/image/Makefile11
2 files changed, 11 insertions, 6 deletions
diff --git a/target/linux/kirkwood/base-files/lib/upgrade/platform.sh b/target/linux/kirkwood/base-files/lib/upgrade/platform.sh
index be5f101673..af0ac7c6e8 100644
--- a/target/linux/kirkwood/base-files/lib/upgrade/platform.sh
+++ b/target/linux/kirkwood/base-files/lib/upgrade/platform.sh
@@ -14,7 +14,8 @@ platform_check_image() {
}
return 0
;;
- "dockstar")
+ "dockstar"|\
+ "iconnect")
nand_do_platform_check $board $1
return $?
;;
@@ -39,7 +40,8 @@ platform_pre_upgrade() {
local board=$(kirkwood_board_name)
case "$board" in
- "dockstar")
+ "dockstar"|\
+ "iconnect")
nand_do_upgrade $1
;;
esac
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index d38ee71555..071c700705 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/image.mk
DEVICE_VARS += DEVICE_DTS KERNEL_SIZE PAGESIZE BLOCKSIZE SUBPAGESIZE KERNEL_IN_UBI
KERNEL_LOADADDR:=0x8000
-TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome
+TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome iconnect
define Device/Default
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
@@ -47,6 +47,12 @@ $(Device/dockstar)
DEVICE_DTS := kirkwood-goflexhome
endef
+define Device/iconnect
+$(Device/dockstar)
+ PROFILES := Generic ICONNECT
+ DEVICE_DTS := kirkwood-iconnect
+endef
+
define Device/linksys-audi
DEVICE_DTS := kirkwood-linksys-audi
PAGESIZE := 512
@@ -176,9 +182,6 @@ Image/InstallKernel/Template/Generic=$(call Image/InstallKernel/Template)
Image/BuildKernel/Template/IB62X0=$(call Image/BuildKernel/Template,ib62x0)
Image/InstallKernel/Template/IB62X0=$(call Image/InstallKernel/Template,ib62x0)
-Image/BuildKernel/Template/ICONNECT=$(call Image/BuildKernel/Template,iconnect)
-Image/InstallKernel/Template/ICONNECT=$(call Image/InstallKernel/Template,iconnect)
-
Image/BuildKernel/Template/IOMEGA_IX2_200=$(call Image/BuildKernel/Template,iomega_ix2_200)
Image/InstallKernel/Template/IOMEGA_IX2_200=$(call Image/InstallKernel/Template,iomega_ix2_200)