aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles/110-nas.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-05-08 20:12:39 +0000
committerLuka Perkov <luka@openwrt.org>2015-05-08 20:12:39 +0000
commite02256fdd9cd2ce1a5283971db7d148c4a2e0d57 (patch)
treebfe078a4cfc317c8b599fc0b43a40bc562ca25cb /target/linux/kirkwood/profiles/110-nas.mk
parentecaa0233e126c4a9a774ef50c6faa7e3cec973ae (diff)
downloadmaster-187ad058-e02256fdd9cd2ce1a5283971db7d148c4a2e0d57.tar.gz
master-187ad058-e02256fdd9cd2ce1a5283971db7d148c4a2e0d57.tar.bz2
master-187ad058-e02256fdd9cd2ce1a5283971db7d148c4a2e0d57.zip
kirkwood: add support for the Seagate GoflexHome
Add Support for the Seagate GoflexHome <http://wiki.openwrt.org/toh/seagate/goflexhome> Signed-off-by: L. D. Pinney <ldpinney@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45647 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/kirkwood/profiles/110-nas.mk')
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
index d87c45c2bf..748efacd56 100644
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ b/target/linux/kirkwood/profiles/110-nas.mk
@@ -20,6 +20,23 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
$(eval $(call Profile,DOCKSTAR))
+define Profile/GOFLEXHOME
+ NAME:=Seagate GoFlexHome
+ PACKAGES:= \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
+ uboot-envtools
+endef
+
+define Profile/GOFLEXHOME/Description
+ Package set compatible with Seagate GoFlexHome
+endef
+
+GOFLEXHOME_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+GOFLEXHOME_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,GOFLEXHOME))
+
define Profile/GOFLEXNET
NAME:=Seagate GoFlexNet
PACKAGES:= \