aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/patches-3.3
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-02 00:33:45 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-02 00:33:45 +0000
commit882530853b300ddd8abe5917c0b8356280f8356b (patch)
treef10729fcec99e15afd2553c3fae3b3c36f9ab8cc /target/linux/kirkwood/patches-3.3
parentb8bfb984bf4298c4b59d5ecb5e7a57e5e0e027bc (diff)
downloadmaster-187ad058-882530853b300ddd8abe5917c0b8356280f8356b.tar.gz
master-187ad058-882530853b300ddd8abe5917c0b8356280f8356b.tar.bz2
master-187ad058-882530853b300ddd8abe5917c0b8356280f8356b.zip
kirkwood: prepare for 3.10
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38279 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/kirkwood/patches-3.3')
-rw-r--r--target/linux/kirkwood/patches-3.3/000-boards.patch66
-rw-r--r--target/linux/kirkwood/patches-3.3/001-partition_map.patch11
-rw-r--r--target/linux/kirkwood/patches-3.3/002-mvsdio_delay.patch32
3 files changed, 109 insertions, 0 deletions
diff --git a/target/linux/kirkwood/patches-3.3/000-boards.patch b/target/linux/kirkwood/patches-3.3/000-boards.patch
new file mode 100644
index 0000000000..22bd2b66b6
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.3/000-boards.patch
@@ -0,0 +1,66 @@
+--- a/arch/arm/mach-kirkwood/Makefile
++++ b/arch/arm/mach-kirkwood/Makefile
+@@ -8,6 +8,8 @@ obj-$(CONFIG_MACH_SHEEVAPLUG) += sheeva
+ obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
+ obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
+ obj-$(CONFIG_MACH_DOCKSTAR) += dockstar-setup.o
++obj-$(CONFIG_MACH_GOFLEXNET) += goflexnet-setup.o
++obj-$(CONFIG_MACH_GOFLEXHOME) += goflexhome-setup.o
+ obj-$(CONFIG_MACH_TS219) += ts219-setup.o tsx1x-common.o
+ obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
+ obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
+@@ -18,5 +20,8 @@ obj-$(CONFIG_MACH_D2NET_V2) += d2net_v2
+ obj-$(CONFIG_MACH_NET2BIG_V2) += netxbig_v2-setup.o lacie_v2-common.o
+ obj-$(CONFIG_MACH_NET5BIG_V2) += netxbig_v2-setup.o lacie_v2-common.o
+ obj-$(CONFIG_MACH_T5325) += t5325-setup.o
++obj-$(CONFIG_MACH_ICONNECT) += iconnect-setup.o
++obj-$(CONFIG_MACH_NAS6210) += nas6210-setup.o
++obj-$(CONFIG_MACH_NSA310) += nsa-310-setup.o
+
+ obj-$(CONFIG_CPU_IDLE) += cpuidle.o
+--- a/arch/arm/mach-kirkwood/Kconfig
++++ b/arch/arm/mach-kirkwood/Kconfig
+@@ -64,6 +64,18 @@ config MACH_DOCKSTAR
+ Say 'Y' here if you want your kernel to support the
+ Seagate FreeAgent DockStar.
+
++config MACH_GOFLEXNET
++ bool "Seagate GoFlex Net"
++ help
++ Say 'Y' here if you want your kernel to support the
++ Seagate GoFlex Net.
++
++config MACH_GOFLEXHOME
++ bool "Seagate GoFlex Home"
++ help
++ Say 'Y' here if you want your kernel to support the
++ Seagate GoFlex Home.
++
+ config MACH_OPENRD
+ bool
+
+@@ -130,6 +142,24 @@ config MACH_T5325
+ Say 'Y' here if you want your kernel to support the
+ HP t5325 Thin Client.
+
++config MACH_ICONNECT
++ bool "Iomega iConnect Wireless"
++ help
++ Say 'Y' here if you want your kernel to support the
++ Iomega iConnect Wireless.
++
++config MACH_NAS6210
++ bool "RaidSonic ICY BOX IB-NAS6210"
++ help
++ Say 'Y' here if you want your kernel to support the
++ RaidSonic ICY BOX IB-NAS6210 device.
++
++config MACH_NSA310
++ bool "ZyXEL NSA-310"
++ help
++ Say 'Y' here if you want your kernel to support the
++ ZyXEL NSA-310 board.
++
+ endmenu
+
+ endif
diff --git a/target/linux/kirkwood/patches-3.3/001-partition_map.patch b/target/linux/kirkwood/patches-3.3/001-partition_map.patch
new file mode 100644
index 0000000000..0f94adc343
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.3/001-partition_map.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c
++++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c
+@@ -33,7 +33,7 @@ static struct mtd_partition sheevaplug_n
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_4M
+ }, {
+- .name = "root",
++ .name = "rootfs",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = MTDPART_SIZ_FULL
+ },
diff --git a/target/linux/kirkwood/patches-3.3/002-mvsdio_delay.patch b/target/linux/kirkwood/patches-3.3/002-mvsdio_delay.patch
new file mode 100644
index 0000000000..46e2a5646c
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.3/002-mvsdio_delay.patch
@@ -0,0 +1,32 @@
+--- a/drivers/mmc/core/sd.c
++++ b/drivers/mmc/core/sd.c
+@@ -389,6 +389,15 @@ int mmc_sd_switch_hs(struct mmc_card *ca
+ return -ENOMEM;
+ }
+
++ /*
++ * Some SDHC cards, notably those with a Sandisk SD controller
++ * (also found in Kingston products) need a bit of slack
++ * before successfully handling the SWITCH command. So far,
++ * cards identifying themselves as "SD04G" and "SD08G" are
++ * affected
++ */
++ udelay(1000);
++
+ err = mmc_sd_switch(card, 1, 0, 1, status);
+ if (err)
+ goto out;
+--- a/drivers/mmc/core/core.c
++++ b/drivers/mmc/core/core.c
+@@ -529,9 +529,9 @@ void mmc_set_data_timeout(struct mmc_dat
+ * The limit is really 250 ms, but that is
+ * insufficient for some crappy cards.
+ */
+- limit_us = 300000;
++ limit_us = 500000;
+ else
+- limit_us = 100000;
++ limit_us = 200000;
+
+ /*
+ * SDHC cards always use these fixed values.