aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-05-29 12:20:39 +0000
committerJohn Crispin <blogic@openwrt.org>2015-05-29 12:20:39 +0000
commitd4aa39c140b3105e4649195832bff2e4ffd6e29f (patch)
tree8e2441f19b10b92601716562406cbc87f9d44134 /target/linux/ixp4xx
parentb3c080638da3fafb98c05f437e47f78840cf576b (diff)
downloadmaster-187ad058-d4aa39c140b3105e4649195832bff2e4ffd6e29f.tar.gz
master-187ad058-d4aa39c140b3105e4649195832bff2e4ffd6e29f.tar.bz2
master-187ad058-d4aa39c140b3105e4649195832bff2e4ffd6e29f.zip
ixp4xx: fix imagebuilder
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45826 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx')
-rw-r--r--target/linux/ixp4xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 7488d757b6..bbd62f0513 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -10,12 +10,12 @@ include $(INCLUDE_DIR)/image.mk
ifdef CONFIG_PACKAGE_apex
define Image/Build/Linksys
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -L $(BIN_DIR)/apex/apex-$(2)-armeb.bin \
+ -L $(KDIR)/apex-$(2)-armeb.bin \
-k $(BIN_DIR)/$(IMG_PREFIX)-$(2)-zImage \
-r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
-p -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).bin
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -F -L $(BIN_DIR)/apex/apex-$(2)-16mb-armeb.bin \
+ -F -L $(KDIR)/apex-$(2)-16mb-armeb.bin \
-k $(BIN_DIR)/$(IMG_PREFIX)-$(2)-zImage \
-r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
-p -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)-16mb.bin