aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-02-23 10:59:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-02-23 10:59:40 +0000
commita73d292127dd4e60f2003c476b68a1782afaee4b (patch)
tree6893168321baffe3f667d58069ad8717ff714e42 /target/linux/ixp4xx
parentad705417a3d3a154cb5c2605c98081ba0df83329 (diff)
downloadmaster-187ad058-a73d292127dd4e60f2003c476b68a1782afaee4b.tar.gz
master-187ad058-a73d292127dd4e60f2003c476b68a1782afaee4b.tar.bz2
master-187ad058-a73d292127dd4e60f2003c476b68a1782afaee4b.zip
kernel: update 3.10 to 3.10.32
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39707 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx')
-rw-r--r--target/linux/ixp4xx/Makefile2
-rw-r--r--target/linux/ixp4xx/patches-3.10/160-delayed_uart_io.patch4
-rw-r--r--target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch4
3 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index b0450114b9..9a7d50997b 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic harddisk
-LINUX_VERSION:=3.10.28
+LINUX_VERSION:=3.10.32
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ixp4xx/patches-3.10/160-delayed_uart_io.patch b/target/linux/ixp4xx/patches-3.10/160-delayed_uart_io.patch
index d24eb3799a..c9cfabbdcd 100644
--- a/target/linux/ixp4xx/patches-3.10/160-delayed_uart_io.patch
+++ b/target/linux/ixp4xx/patches-3.10/160-delayed_uart_io.patch
@@ -57,7 +57,7 @@
if (!port->mapbase)
break;
-@@ -3091,6 +3113,7 @@ static int serial8250_probe(struct platf
+@@ -3095,6 +3117,7 @@ static int serial8250_probe(struct platf
uart.port.set_termios = p->set_termios;
uart.port.pm = p->pm;
uart.port.dev = &dev->dev;
@@ -65,7 +65,7 @@
uart.port.irqflags |= irqflag;
ret = serial8250_register_8250_port(&uart);
if (ret < 0) {
-@@ -3242,6 +3265,7 @@ int serial8250_register_8250_port(struct
+@@ -3246,6 +3269,7 @@ int serial8250_register_8250_port(struct
uart->port.flags = up->port.flags | UPF_BOOT_AUTOCONF;
uart->bugs = up->bugs;
uart->port.mapbase = up->port.mapbase;
diff --git a/target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch b/target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch
index 2a11ba8d09..c46f516bd6 100644
--- a/target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch
+++ b/target/linux/ixp4xx/patches-3.10/600-skb_avoid_dmabounce.patch
@@ -1,6 +1,6 @@
--- a/net/core/skbuff.c
+++ b/net/core/skbuff.c
-@@ -238,6 +238,9 @@ struct sk_buff *__alloc_skb(unsigned int
+@@ -208,6 +208,9 @@ struct sk_buff *__alloc_skb(unsigned int
if (sk_memalloc_socks() && (flags & SKB_ALLOC_RX))
gfp_mask |= __GFP_MEMALLOC;
@@ -10,7 +10,7 @@
/* Get the HEAD */
skb = kmem_cache_alloc_node(cache, gfp_mask & ~__GFP_DMA, node);
-@@ -1082,6 +1085,10 @@ int pskb_expand_head(struct sk_buff *skb
+@@ -1052,6 +1055,10 @@ int pskb_expand_head(struct sk_buff *skb
if (skb_shared(skb))
BUG();