aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
commit62ccdcedae255174a46ef74d2e0a887f16ddb30f (patch)
treec61f885f5bdc75674f275920f157438d4bc748a7 /target/linux/ixp4xx/image
parent2c3d7a423cabb394a9933ad18b317158130fbd74 (diff)
downloadmaster-187ad058-62ccdcedae255174a46ef74d2e0a887f16ddb30f.tar.gz
master-187ad058-62ccdcedae255174a46ef74d2e0a887f16ddb30f.tar.bz2
master-187ad058-62ccdcedae255174a46ef74d2e0a887f16ddb30f.zip
make the image filenames a bit shorter
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9533 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx/image')
-rw-r--r--target/linux/ixp4xx/image/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 70ff0ebf56..167bd1d5fa 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -22,14 +22,14 @@ ifneq ($(CONFIG_IXP4XX_INCLUDE_UCODE),)
define Image/Build/slug
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
- -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
- -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
- -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+ -k $(BIN_DIR)/openwrt-nslu2-zImage \
+ -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
+ -p -o $(BIN_DIR)/openwrt-nslu2-$(1).bin
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-F -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
- -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
- -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
- -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1)-16mb.bin
+ -k $(BIN_DIR)/openwrt-nslu2-zImage \
+ -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
+ -p -o $(BIN_DIR)/openwrt-nslu2-$(1)-16mb.bin
endef
endif
@@ -51,7 +51,7 @@ define Image/Prepare
endef
define Image/BuildKernel
- cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
+ cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
# $(shell BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh)
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
endef
@@ -61,17 +61,17 @@ define Image/Build
endef
define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
endef
define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
$(call Image/Build/slug,$(1))
endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
$(call Image/Build/slug,$(1))
endef