aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-14 16:41:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-14 16:41:33 +0000
commitd78864ef7c7b550de88f8494fed22bf6854c6627 (patch)
tree1a38200fe1a33cb965650ca687167175938fbedd /target/linux/ixp4xx-2.6
parent881d8c8f18644c9dbebd14b0783ee56782964bce (diff)
downloadmaster-187ad058-d78864ef7c7b550de88f8494fed22bf6854c6627.tar.gz
master-187ad058-d78864ef7c7b550de88f8494fed22bf6854c6627.tar.bz2
master-187ad058-d78864ef7c7b550de88f8494fed22bf6854c6627.zip
Upgrade to Linux 2.6.19
- Includes large parts of the patch from #1021 by dpalffy - Includes RB532 NAND driver changes by n0-1 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5789 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx-2.6')
-rw-r--r--target/linux/ixp4xx-2.6/Makefile5
-rw-r--r--target/linux/ixp4xx-2.6/patches/100-npe_driver.patch2
2 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/ixp4xx-2.6/Makefile b/target/linux/ixp4xx-2.6/Makefile
index 52d607d566..3c995bf79a 100644
--- a/target/linux/ixp4xx-2.6/Makefile
+++ b/target/linux/ixp4xx-2.6/Makefile
@@ -14,10 +14,9 @@ FEATURES:=jffs2
define Target/Description
endef
-
-LINUX_VERSION:=2.6.17
+LINUX_VERSION:=2.6.19
LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+LINUX_KERNEL_MD5SUM:=443c265b57e87eadc0c677c3acc37e20
include $(INCLUDE_DIR)/kernel-build.mk
$(eval $(call BuildKernel))
diff --git a/target/linux/ixp4xx-2.6/patches/100-npe_driver.patch b/target/linux/ixp4xx-2.6/patches/100-npe_driver.patch
index e65838f3c2..0e13e1f7fb 100644
--- a/target/linux/ixp4xx-2.6/patches/100-npe_driver.patch
+++ b/target/linux/ixp4xx-2.6/patches/100-npe_driver.patch
@@ -750,7 +750,7 @@ diff -Nur linux-2.6.17/drivers/net/ixp4xx/ixp4xx_qmgr.c linux-2.6.17-owrt/driver
+ return 0;
+}
+
-+static irqreturn_t irq_qm1(int irq, void *dev_id, struct pt_regs *regs)
++static irqreturn_t irq_qm1(int irq, void *dev_id)
+{
+ struct qm_qmgr *qmgr = dev_id;
+ int offs, reg;