aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/image/Makefile
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-08-10 13:09:12 +0000
committerRod Whitby <rod@whitby.id.au>2007-08-10 13:09:12 +0000
commitdc8987077d5e93e15dcfc693375ae50e98613058 (patch)
tree7605e6ee4da1d93d238d5c06830f1af1f88156db /target/linux/ixp4xx-2.6/image/Makefile
parente9ccccf63da2bf1ab6e74c57aa940fe835fbf941 (diff)
downloadmaster-187ad058-dc8987077d5e93e15dcfc693375ae50e98613058.tar.gz
master-187ad058-dc8987077d5e93e15dcfc693375ae50e98613058.tar.bz2
master-187ad058-dc8987077d5e93e15dcfc693375ae50e98613058.zip
ixp4xx-2.6/nslu2: Added support for building 16MB images
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8388 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx-2.6/image/Makefile')
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index 8d05a1b8f1..70ff0ebf56 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -25,6 +25,11 @@ ifneq ($(CONFIG_IXP4XX_INCLUDE_UCODE),)
-k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+ BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+ -F -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+ -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+ -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+ -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1)-16mb.bin
endef
endif