aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/image/Makefile
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-01-01 05:25:09 +0000
committerRod Whitby <rod@whitby.id.au>2007-01-01 05:25:09 +0000
commita01866ca1c079d9fec1ce58139233d563ab57c5e (patch)
tree6c5d63b8ef9eab1a54834c538f6b6941cc6d1d1a /target/linux/ixp4xx-2.6/image/Makefile
parenta67c6acc98000f73be2c0f92e4839d789f12fd41 (diff)
downloadmaster-187ad058-a01866ca1c079d9fec1ce58139233d563ab57c5e.tar.gz
master-187ad058-a01866ca1c079d9fec1ce58139233d563ab57c5e.tar.bz2
master-187ad058-a01866ca1c079d9fec1ce58139233d563ab57c5e.zip
Added the npe-ucode package to create the microcode for the IXP4XX NPE ethernet driver. Note that the user has to download the actual Intel microcode package themselves (agreeing to the Intel license to do so).
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5951 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx-2.6/image/Makefile')
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index fc17c0f9ee..3c85823913 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -12,10 +12,15 @@ define Build/Compile
BUILD_DIR="$(KDIR)" \
TARGET="$(KDIR)" \
install
+ $(MAKE) -C npe-ucode \
+ BUILD_DIR="$(KDIR)" \
+ TARGET="$(KDIR)" \
+ install
endef
define Build/Clean
$(MAKE) -C apex clean
+ $(MAKE) -C npe-ucode clean
endef
define Image/Prepare
@@ -41,8 +46,8 @@ define Image/Build/jffs2-128k
-L $(KDIR)/apex-nslu2-armeb.bin \
-k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+ -m $(BIN_DIR)/NPE-B \
-p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
-# -m $(BIN_DIR)/NPE-B
endef
$(eval $(call BuildImage))