aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-20 18:45:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-20 18:45:54 +0000
commit10a2a8ee2694e8d94b268b0f52d7123051f2d9c7 (patch)
treec155ee9a0682f0639ee9987da9425b545b95df65 /target/linux/ixp4xx-2.6/image/Makefile
parentaac11b03c1e2d61b1221aeabadfe2958e87ad164 (diff)
downloadmaster-187ad058-10a2a8ee2694e8d94b268b0f52d7123051f2d9c7.tar.gz
master-187ad058-10a2a8ee2694e8d94b268b0f52d7123051f2d9c7.tar.bz2
master-187ad058-10a2a8ee2694e8d94b268b0f52d7123051f2d9c7.zip
turn the IXP4xx microcode check into a prereq check so that the error message is displayed before the compile starts
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6148 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx-2.6/image/Makefile')
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index cbbb29b6b9..bb33aff7f8 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -51,3 +51,17 @@ define Image/Build/jffs2-128k
endef
$(eval $(call BuildImage))
+
+UCODEFILE:=IPL_ixp400NpeLibrary-2_3.zip
+
+define Require/npe-ucode
+ [ -f $(DL_DIR)/$(UCODEFILE) ]
+endef
+
+$(eval $(call Require,npe-ucode, \
+ You must manually download $(UCODEFILE) from \\\
+ http://www.intel.com/design/network/products/npfamily/ixp400_current.htm \\\
+ and put it in $(DL_DIR). \\\
+ You will need to agree to the Intel Public License to do so - please do read it! \
+))
+