aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
commitb5bb9272ee773d30c1fde2da17c087618264ab6f (patch)
tree682cca857e1946d5a258823cfa55f3c40d9daa64 /target/linux/ipq806x
parentb5f4a9f364263f9f1fdc5093b00b223154aaf5fc (diff)
downloadmaster-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.gz
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.bz2
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46361 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index db5bf0acbc..9a1bad8fdf 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -9,7 +9,7 @@ UBINIZE_OPTS = -m 2048 -p 128KiB
E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024)))
define Image/BuildKernel/FIT
- gzip -9 -c $(KDIR)/Image > $(KDIR)/Image.gz
+ gzip -9n -c $(KDIR)/Image > $(KDIR)/Image.gz
$(call CompressLzma,$(KDIR)/Image,$(KDIR)/Image.gz)
$(call Image/BuildKernel/MkFIT,$(1), $(KDIR)/Image.gz, $(LINUX_DIR)/arch/arm/boot/dts/$(1).dtb,gzip,0x42208000,0x42208000)
$(CP) $(KDIR)/fit-$(1).itb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage.itb