aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-11-04 11:33:31 +0000
committerJonas Gorski <jogo@openwrt.org>2015-11-04 11:33:31 +0000
commit9011e2ab0a9d4018e91a3178e36840aecf52901b (patch)
treeeb606ccfa1981c09b7d6d40bfed56e668a54bbfd /target/linux/ipq806x
parentcea1fbf79a1230bdff5b97a2ac67ae43c3e993de (diff)
downloadmaster-187ad058-9011e2ab0a9d4018e91a3178e36840aecf52901b.tar.gz
master-187ad058-9011e2ab0a9d4018e91a3178e36840aecf52901b.tar.bz2
master-187ad058-9011e2ab0a9d4018e91a3178e36840aecf52901b.zip
ipq806x: fix BOARD_NAME spellings
the board names used by the upgrade check differ from the device names in case, so always set them. We can't rely on tolower or similar since different locales might have different rules for lower case letters, so set them explicitily. Fixes sysupgrade rejecting *-sysupgrade.tar because of the difference. Signed-off-by: Kaspar Schleiser <kaspar@schleiser.de> Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47381 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/image/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index c59e6d446e..14cf442f43 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -47,8 +47,9 @@ define Device/Default
KERNEL_PREFIX := $$(IMAGE_PREFIX)
IMAGES :=
KERNEL_IN_UBI :=
+ BOARD_NAME :=
endef
-DEVICE_VARS += DEVICE_DTS KERNEL_IN_UBI
+DEVICE_VARS += DEVICE_DTS KERNEL_IN_UBI BOARD_NAME
define Device/LegacyImage
KERNEL_SUFFIX := -uImage
@@ -78,12 +79,11 @@ define Device/DniImage
KERNEL_NAME := zImage
NETGEAR_BOARD_ID :=
NETGEAR_HW_ID :=
- BOARD_NAME :=
IMAGES := factory.img sysupgrade.tar
IMAGE/factory.img := append-kernel | append-ubi | netgear-dni
IMAGE/sysupgrade.tar = sysupgrade-nand
endef
-DEVICE_VARS += KERNEL_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID DEVICE_BLOCK_SIZE DEVICE_PAGE_SIZE BOARD_NAME
+DEVICE_VARS += KERNEL_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID DEVICE_BLOCK_SIZE DEVICE_PAGE_SIZE
define Device/AP148
$(call Device/FitImage)
@@ -91,6 +91,7 @@ define Device/AP148
DEVICE_DTS := qcom-ipq8064-ap148
BLOCKSIZE := 128KiB
PAGESIZE := 2048
+ BOARD_NAME := ap148
endef
define Device/AP148-legacy
@@ -99,13 +100,14 @@ define Device/AP148-legacy
DEVICE_DTS := qcom-ipq8064-ap148
BLOCKSIZE := 128KiB
PAGESIZE := 2048
- BOARD_NAME := AP148
+ BOARD_NAME := ap148
endef
define Device/DB149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149
KERNEL_INSTALL := 1
+ BOARD_NAME := db149
endef
define Device/R7500