aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-05-29 11:28:44 +0000
committerJohn Crispin <blogic@openwrt.org>2015-05-29 11:28:44 +0000
commit63da3677605b0b0915fbf0c1407a272c800f085e (patch)
tree52d76b475043f64d5f6555d25f27467d884ddb9c /target/linux/ipq806x
parente9386e5b527bf452abcb92b3b5b86c6be92ff8e4 (diff)
downloadmaster-187ad058-63da3677605b0b0915fbf0c1407a272c800f085e.tar.gz
master-187ad058-63da3677605b0b0915fbf0c1407a272c800f085e.tar.bz2
master-187ad058-63da3677605b0b0915fbf0c1407a272c800f085e.zip
ipq806x: fix imagebuilder
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45823 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ipq806x')
-rw-r--r--target/linux/ipq806x/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index e2346e6319..db5bf0acbc 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -19,8 +19,12 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endif
endef
+define Image/Prepare
+ $(CP) $(LINUX_DIR)/vmlinux $(KDIR)/$(IMG_PREFIX)-vmlinux.elf
+endef
+
define Image/BuildKernel
- $(CP) $(LINUX_DIR)/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+ $(CP) $(KDIR)/$(IMG_PREFIX)-vmlinux.elf $(BIN_DIR)
$(call Image/BuildKernel/FIT,qcom-ipq8064-ap148)
$(call Image/BuildKernel/FIT,qcom-ipq8064-db149)
endef