aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-01-19 10:16:36 +0000
committerJohn Crispin <blogic@openwrt.org>2016-01-19 10:16:36 +0000
commitd1e706e8b7dc148eba9d4f0e9a4af24930f1d083 (patch)
treea4a3723808695c1f0c2182204861d60fbd7c4b95 /target/linux/ipq806x/image/Makefile
parenta988dbf082e3bfef71ff136d81b3311929ffe97f (diff)
downloadmaster-187ad058-d1e706e8b7dc148eba9d4f0e9a4af24930f1d083.tar.gz
master-187ad058-d1e706e8b7dc148eba9d4f0e9a4af24930f1d083.tar.bz2
master-187ad058-d1e706e8b7dc148eba9d4f0e9a4af24930f1d083.zip
ipq806x: Add support for Netgear D7800
Signed-off-by: Tathagata Das <tathagata@alumnux.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48360 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 58c4e1e872..ff8b2c7d9b 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -104,6 +104,17 @@ define Device/AP148-legacy
BOARD_NAME := ap148
endef
+define Device/D7800
+ $(call Device/DniImage)
+ DEVICE_DTS := qcom-ipq8064-d7800
+ KERNEL_SIZE := 2097152
+ NETGEAR_BOARD_ID := D7800
+ NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ BOARD_NAME := d7800
+endef
+
define Device/DB149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149
@@ -122,6 +133,6 @@ define Device/R7500
BOARD_NAME := r7500
endef
-TARGET_DEVICES += AP148 AP148-legacy DB149 R7500
+TARGET_DEVICES += AP148 AP148-legacy D7800 DB149 R7500
$(eval $(call BuildImage))