aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/image
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-17 11:54:52 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-17 11:54:52 +0000
commitb32bb886f30ef7e0e5e1af29e90a63c5acfb6937 (patch)
tree20e98f2c63f2b128d8fd4f2238435d805a67a44e /target/linux/imx6/image
parent092ba3c09a0619b22ee74e3b3017d4b65b41eeab (diff)
downloadmaster-187ad058-b32bb886f30ef7e0e5e1af29e90a63c5acfb6937.tar.gz
master-187ad058-b32bb886f30ef7e0e5e1af29e90a63c5acfb6937.tar.bz2
master-187ad058-b32bb886f30ef7e0e5e1af29e90a63c5acfb6937.zip
imx6: fix file names when building images
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38434 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/imx6/image')
-rw-r--r--target/linux/imx6/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index aad15271a0..a0772727d2 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -34,7 +34,7 @@ endef
# board-specific sysupgrade image
define BuildFirmware/Generic
- dd if=$(BIN_DIR)/openwrt-$(1)-uImage.itb of=$(KDIR)/uImage.pad bs=64k conv=sync; \
+ dd if=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage.itb of=$(KDIR)/uImage.pad bs=64k conv=sync; \
dd if=$(KDIR)/root.$(2) of=$(KDIR)/root.$(2).pad bs=128k conv=sync; \
sh $(TOPDIR)/scripts/combined-image.sh \
$(KDIR)/uImage.pad \
@@ -52,10 +52,10 @@ endef
# rootfs and board-specific combined kernel+rootfs for convenience
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.$(1))
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync; \
$(foreach board,$(BOARDS),
( \
- dd if=$(BIN_DIR)/openwrt-$(board)-uImage.itb bs=2048k conv=sync; \
+ dd if=$(BIN_DIR)/$(IMG_PREFIX)-$(board)-uImage.itb bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/$(IMG_PREFIX)-$(board)-$(1).bin
)