aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-04-11 12:39:33 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-04-11 12:39:33 +0000
commitffde361c073ae695eec9dcc60d83e326d31126e6 (patch)
tree65ea22d82346a0930d8770b02f9dd48dc900c599 /target/linux/image
parent9b552894c0062fa574661bbc7d35c8a632a9568b (diff)
downloadmaster-187ad058-ffde361c073ae695eec9dcc60d83e326d31126e6.tar.gz
master-187ad058-ffde361c073ae695eec9dcc60d83e326d31126e6.tar.bz2
master-187ad058-ffde361c073ae695eec9dcc60d83e326d31126e6.zip
Add an MTX-1 specific patch to avoid functions redefinition at compile-time.
Build a full target git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3616 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image')
-rw-r--r--target/linux/image/au1000/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/image/au1000/Makefile b/target/linux/image/au1000/Makefile
new file mode 100644
index 0000000000..04a89f9b19
--- /dev/null
+++ b/target/linux/image/au1000/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+
+
+ifeq ($(FS),jffs2-8MB)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img: $(KDIR)/root.$(FS)
+ $(CP) $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
+
+endif
+
+
+ifeq ($(FS),tgz)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/root.tar.gz
+ $(CP) $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
+
+endif
+
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/vmlinux
+ $(CP) $^ $@
+
+
+clean:
+prepare:
+compile:
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+install-ib:
+ mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
+ $(CP) $(KDIR)/bzImage $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/