aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-09 21:49:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-09 21:49:48 +0000
commit2111fcc44fc85bc9114c17be86581402e40548f8 (patch)
tree60cc06e60bfe848a997d7577cf3aa55ac38306f2 /target/linux/image
parent86278453fa35217f0ce438c79aa1d8e83d10ac39 (diff)
downloadmaster-187ad058-2111fcc44fc85bc9114c17be86581402e40548f8.tar.gz
master-187ad058-2111fcc44fc85bc9114c17be86581402e40548f8.tar.bz2
master-187ad058-2111fcc44fc85bc9114c17be86581402e40548f8.zip
ar7: clean up system code, add code to generate firmware images
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1386 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image')
-rw-r--r--target/linux/image/ar7/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/target/linux/image/ar7/Makefile b/target/linux/image/ar7/Makefile
index ee78cc91e0..b2683dbd84 100644
--- a/target/linux/image/ar7/Makefile
+++ b/target/linux/image/ar7/Makefile
@@ -41,10 +41,28 @@ $(BIN_DIR)/openwrt-ar7-zimage.bin: $(KDIR)/vmlinux.gz compile
-o $(KDIR)/loader
$(TARGET_CROSS)objcopy -O srec $(KDIR)/loader $(KDIR)/ram_zimage.sre
$(PKG_BUILD_DIR)/srec2bin $(KDIR)/ram_zimage.sre $@
+
+$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin:
+ dd if=$(BIN_DIR)/openwrt-ar7-zimage.bin of=$@ bs=786432 conv=sync
+ cat $(BUILD_DIR)/linux-$(KERNEL)-ar7/root.$(FS) >> $@
+
+define pattern_template
+$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin: $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin
+ (dd if=/dev/zero bs=16 count=1; cat $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin) | \
+ $(STAGING_DIR)/bin/addpattern -p $(1) -o $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
+install: $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
+endef
+
+$(eval $(call pattern_template,WA22))
+$(eval $(call pattern_template,WAG2))
+$(eval $(call pattern_template,WA21))
+
clean:
rm -rf $(PKG_BUILD_DIR)
+ rm -f $(BIN_DIR)/openwrt-ar7*
+
prepare: $(PKG_BUILD_DIR) $(PKG_BUILD_DIR)/zimage.script $(PKG_BUILD_DIR)/ld.script
compile: prepare $(PKG_BUILD_DIR)/loader.o $(PKG_BUILD_DIR)/srec2bin
-install: $(BIN_DIR)/openwrt-ar7-zimage.bin
+install: $(BIN_DIR)/openwrt-ar7-zimage.bin $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin