aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-12 19:08:03 +0000
committerMike Baker <mbm@openwrt.org>2006-05-12 19:08:03 +0000
commit20e4ecc021ee9aa4b799b065732f39d9daa5a2c5 (patch)
tree6c8591525420de7c8afd05b2261efe6b9071196a /target/linux/image
parent7b37cc4da9c275661854482bb61046d4d7a8435f (diff)
downloadmaster-187ad058-20e4ecc021ee9aa4b799b065732f39d9daa5a2c5.tar.gz
master-187ad058-20e4ecc021ee9aa4b799b065732f39d9daa5a2c5.tar.bz2
master-187ad058-20e4ecc021ee9aa4b799b065732f39d9daa5a2c5.zip
fix BR2_ and CONFIG_ issues
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3769 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image')
-rw-r--r--target/linux/image/Makefile6
-rw-r--r--target/linux/image/aruba/Makefile2
-rw-r--r--target/linux/image/jffs2.mk2
3 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/image/Makefile b/target/linux/image/Makefile
index af7cd0e8d5..ce807b3027 100644
--- a/target/linux/image/Makefile
+++ b/target/linux/image/Makefile
@@ -2,15 +2,15 @@ include $(TOPDIR)/rules.mk
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
-ifeq ($(BR2_TARGET_ROOTFS_JFFS2),y)
+ifeq ($(CONFIG_TARGET_ROOTFS_JFFS2),y)
include ./jffs2.mk
endif
-ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_LZMA),y)
+ifeq ($(CONFIG_TARGET_ROOTFS_SQUASHFS_LZMA),y)
include ./squashfs.mk
endif
-ifeq ($(BR2_TARGET_ROOTFS_TGZ),y)
+ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
include ./tgz.mk
endif
diff --git a/target/linux/image/aruba/Makefile b/target/linux/image/aruba/Makefile
index a2cceaf0c1..0ddde20266 100644
--- a/target/linux/image/aruba/Makefile
+++ b/target/linux/image/aruba/Makefile
@@ -36,7 +36,7 @@ ifeq ($(FS),jffs2-4MB)
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari: $(KDIR)/loader.elf
./addVersion -n ArubaOS $(KDIR)/loader.elf $@ version
-ifneq ($(BR2_ARUBA_RAMDISK),y)
+ifneq ($(CONFIG_ARUBA_RAMDISK),y)
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari $(KDIR)/root.$(FS)
@dd if=$< of=$@.tmp bs=655360 conv=sync
@cat $(KDIR)/root.$(FS) >> $@.tmp
diff --git a/target/linux/image/jffs2.mk b/target/linux/image/jffs2.mk
index 1b0c3a778f..7df3aedbcf 100644
--- a/target/linux/image/jffs2.mk
+++ b/target/linux/image/jffs2.mk
@@ -1,4 +1,4 @@
-ifneq ($(BR2_mips),y)
+ifneq ($(CONFIG_mips),y)
JFFS2OPTS := --pad --little-endian --squash
else
JFFS2OPTS := --pad --big-endian --squash