aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image/brcm
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-08-29 10:47:33 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-08-29 10:47:33 +0000
commitdfd060f33a8b97c131207384da765de77f1f45f3 (patch)
tree45bff8104a5af8ab7991a572520a3f1a89e8ac20 /target/linux/image/brcm
parent55d24f868880af2a5ed9d188dd63dc968c3c9fcf (diff)
downloadmaster-187ad058-dfd060f33a8b97c131207384da765de77f1f45f3.tar.gz
master-187ad058-dfd060f33a8b97c131207384da765de77f1f45f3.tar.bz2
master-187ad058-dfd060f33a8b97c131207384da765de77f1f45f3.zip
make a image for netgear, loader need to be ELF
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1784 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image/brcm')
-rw-r--r--target/linux/image/brcm/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/image/brcm/Makefile b/target/linux/image/brcm/Makefile
index c0c83c52f0..09f2d1429c 100644
--- a/target/linux/image/brcm/Makefile
+++ b/target/linux/image/brcm/Makefile
@@ -27,6 +27,15 @@ endif
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx:
$(STAGING_DIR)/bin/trx -o $@ $(BUILD_DIR)/loader.gz $(KDIR)/vmlinux.lzma $(TRXALIGN) $(KDIR)/root.$(FS)
+ifeq ($(KERNEL),2.6)
+FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
+
+$(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+ dd if=$(BUILD_DIR)/loader-0.04/loader.o of=$@ bs=65536 conv=sync
+ cat $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx >> $@
+
+install: $(BIN_DIR)/openwrt-wgt634u-2.6-$(FSNAME).bin
+endif
ifeq ($(KERNEL),2.4)
FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))