aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/patches-2.6.30/160-led.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2009-10-08 22:24:49 +0000
committerJohn Crispin <blogic@openwrt.org>2009-10-08 22:24:49 +0000
commitfe2eb2406d5600eb56d91c967a2d92c14eb6cc18 (patch)
treee263c035214c31d62f8665c339ba16b257c4667c /target/linux/ifxmips/patches-2.6.30/160-led.patch
parent6ca9f5f2d7721ab48f7e245a72b0b8f381f8dc7e (diff)
downloadmaster-187ad058-fe2eb2406d5600eb56d91c967a2d92c14eb6cc18.tar.gz
master-187ad058-fe2eb2406d5600eb56d91c967a2d92c14eb6cc18.tar.bz2
master-187ad058-fe2eb2406d5600eb56d91c967a2d92c14eb6cc18.zip
ifxmips: move header files, split up patches, rename some files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18010 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ifxmips/patches-2.6.30/160-led.patch')
-rw-r--r--target/linux/ifxmips/patches-2.6.30/160-led.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ifxmips/patches-2.6.30/160-led.patch b/target/linux/ifxmips/patches-2.6.30/160-led.patch
new file mode 100644
index 0000000000..aca11d5535
--- /dev/null
+++ b/target/linux/ifxmips/patches-2.6.30/160-led.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.30.5/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.30.5.orig/drivers/leds/Kconfig 2009-09-02 18:22:49.000000000 +0200
++++ linux-2.6.30.5/drivers/leds/Kconfig 2009-09-02 18:29:51.000000000 +0200
+@@ -227,6 +227,12 @@
+ This option enables support for BD2802GU RGB LED driver chips
+ accessed via the I2C bus.
+
++config LEDS_IFXMIPS
++ tristate "LED Support for IFXMIPS LEDs"
++ depends on LEDS_CLASS && IFXMIPS
++ help
++ This option enables support for the CM-X270 LEDs.
++
+ comment "LED Triggers"
+
+ config LEDS_TRIGGERS
+Index: linux-2.6.30.5/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.30.5.orig/drivers/leds/Makefile 2009-09-02 18:22:49.000000000 +0200
++++ linux-2.6.30.5/drivers/leds/Makefile 2009-09-02 18:31:23.000000000 +0200
+@@ -27,6 +27,7 @@
+ obj-$(CONFIG_LEDS_DA903X) += leds-da903x.o
+ obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
+ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
++obj-$(CONFIG_LEDS_IFXMIPS) += leds-ifxmips.o
+
+ # LED SPI Drivers
+ obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o