aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/patches-2.6.30/130-ethernet.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2009-10-08 22:24:49 +0000
committerJohn Crispin <blogic@openwrt.org>2009-10-08 22:24:49 +0000
commitfe2eb2406d5600eb56d91c967a2d92c14eb6cc18 (patch)
treee263c035214c31d62f8665c339ba16b257c4667c /target/linux/ifxmips/patches-2.6.30/130-ethernet.patch
parent6ca9f5f2d7721ab48f7e245a72b0b8f381f8dc7e (diff)
downloadmaster-187ad058-fe2eb2406d5600eb56d91c967a2d92c14eb6cc18.tar.gz
master-187ad058-fe2eb2406d5600eb56d91c967a2d92c14eb6cc18.tar.bz2
master-187ad058-fe2eb2406d5600eb56d91c967a2d92c14eb6cc18.zip
ifxmips: move header files, split up patches, rename some files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18010 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ifxmips/patches-2.6.30/130-ethernet.patch')
-rw-r--r--target/linux/ifxmips/patches-2.6.30/130-ethernet.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ifxmips/patches-2.6.30/130-ethernet.patch b/target/linux/ifxmips/patches-2.6.30/130-ethernet.patch
new file mode 100644
index 0000000000..da87bb78c5
--- /dev/null
+++ b/target/linux/ifxmips/patches-2.6.30/130-ethernet.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.30.5/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.30.5.orig/drivers/net/Kconfig 2009-09-02 18:22:49.000000000 +0200
++++ linux-2.6.30.5/drivers/net/Kconfig 2009-09-02 18:29:51.000000000 +0200
+@@ -353,6 +353,12 @@
+
+ source "drivers/net/arm/Kconfig"
+
++config IFXMIPS_MII0
++ tristate "Infineon IFXMips eth0 driver"
++ depends on IFXMIPS
++ help
++ Support for the MII0 inside the IFXMips SOC
++
+ config AX88796
+ tristate "ASIX AX88796 NE2000 clone support"
+ depends on ARM || MIPS || SUPERH
+Index: linux-2.6.30.5/drivers/net/Makefile
+===================================================================
+--- linux-2.6.30.5.orig/drivers/net/Makefile 2009-09-02 18:22:49.000000000 +0200
++++ linux-2.6.30.5/drivers/net/Makefile 2009-09-02 18:30:37.000000000 +0200
+@@ -234,6 +234,7 @@
+ obj-$(CONFIG_MLX4_CORE) += mlx4/
+ obj-$(CONFIG_ENC28J60) += enc28j60.o
+ obj-$(CONFIG_ETHOC) += ethoc.o
++obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
+
+ obj-$(CONFIG_XTENSA_XT2000_SONIC) += xtsonic.o
+