aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-12-20 22:29:45 +0000
committerJohn Crispin <blogic@openwrt.org>2007-12-20 22:29:45 +0000
commit726b82e53124812a26dc9b3a4afd64f676fbf0ff (patch)
treea7fb7168faa3c73288de9f7af0b7201470dcd672 /target/linux/ifxmips/image
parentab8e59334fddb03c60b58581ca10b1c7a8ac7aa9 (diff)
downloadmaster-187ad058-726b82e53124812a26dc9b3a4afd64f676fbf0ff.tar.gz
master-187ad058-726b82e53124812a26dc9b3a4afd64f676fbf0ff.tar.bz2
master-187ad058-726b82e53124812a26dc9b3a4afd64f676fbf0ff.zip
move danube folder to ifxmips, to allow future integration of the other chips
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9815 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ifxmips/image')
-rw-r--r--target/linux/ifxmips/image/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/ifxmips/image/Makefile b/target/linux/ifxmips/image/Makefile
new file mode 100644
index 0000000000..41082982b9
--- /dev/null
+++ b/target/linux/ifxmips/image/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ mkimage -A mips -O linux -T kernel -a 0x80002000 -C lzma -e \
+ 0x80002000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage
+
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build/squashfs
+ cat $(KDIR)/uImage $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image)
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/uImage of=$(KDIR)/uImage.$(1) bs=64k conv=sync
+ cat $(KDIR)/uImage.$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+$(eval $(call BuildImage))