aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/files/arch/mips
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2010-03-30 21:06:27 +0000
committerJohn Crispin <blogic@openwrt.org>2010-03-30 21:06:27 +0000
commit0e477f3816d2a78936bdbbfbf36bb9bd40bc8aad (patch)
treef43536f6cd2c0f58593b0eab42402e68238501e1 /target/linux/ifxmips/files/arch/mips
parent52c5d88da9e06edcb5d1b2cc3bef42b09e6988dd (diff)
downloadmaster-187ad058-0e477f3816d2a78936bdbbfbf36bb9bd40bc8aad.tar.gz
master-187ad058-0e477f3816d2a78936bdbbfbf36bb9bd40bc8aad.tar.bz2
master-187ad058-0e477f3816d2a78936bdbbfbf36bb9bd40bc8aad.zip
[ifxmips] prepare kernel for voip
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20613 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ifxmips/files/arch/mips')
-rw-r--r--target/linux/ifxmips/files/arch/mips/ifxmips/Makefile2
-rw-r--r--target/linux/ifxmips/files/arch/mips/ifxmips/timer.c10
2 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ifxmips/files/arch/mips/ifxmips/Makefile b/target/linux/ifxmips/files/arch/mips/ifxmips/Makefile
index 9710645b99..c330be6344 100644
--- a/target/linux/ifxmips/files/arch/mips/ifxmips/Makefile
+++ b/target/linux/ifxmips/files/arch/mips/ifxmips/Makefile
@@ -1 +1 @@
-obj-y := reset.o prom.o setup.o irq.o dma-core.o pmu.o board.o clock.o gpio.o
+obj-y := reset.o prom.o setup.o irq.o dma-core.o pmu.o board.o clock.o gpio.o timer.o
diff --git a/target/linux/ifxmips/files/arch/mips/ifxmips/timer.c b/target/linux/ifxmips/files/arch/mips/ifxmips/timer.c
index d05df2283c..31e606c85a 100644
--- a/target/linux/ifxmips/files/arch/mips/ifxmips/timer.c
+++ b/target/linux/ifxmips/files/arch/mips/ifxmips/timer.c
@@ -13,11 +13,11 @@
#include <asm/irq.h>
#include <asm/div64.h>
-#include <asm/ifxmips/ifxmips.h>
-#include <asm/ifxmips/ifxmips_irq.h>
-#include <asm/mach-ifxmips/cgu.h>
-#include <asm/ifxmips/ifxmips_gptu.h>
-#include <asm/ifxmips/ifxmips_pmu.h>
+#include <ifxmips.h>
+#include <ifxmips_irq.h>
+#include <ifxmips_cgu.h>
+#include <ifxmips_gptu.h>
+#include <ifxmips_pmu.h>
#define MAX_NUM_OF_32BIT_TIMER_BLOCKS 6