aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/Makefile
diff options
context:
space:
mode:
authorOpenWrt Developers <openwrt-devel@openwrt.org>2009-03-04 14:46:02 +0000
committerOpenWrt Developers <openwrt-devel@openwrt.org>2009-03-04 14:46:02 +0000
commite2a4217449add9080b6f257ec6b28694dd0e2c10 (patch)
tree617615dec93d41efd40b52c5d72a10b43d1fe247 /target/linux/ifxmips/Makefile
parent038b9cc3e4501a98a6a29e865340d4756cfb2c07 (diff)
downloadmaster-187ad058-e2a4217449add9080b6f257ec6b28694dd0e2c10.tar.gz
master-187ad058-e2a4217449add9080b6f257ec6b28694dd0e2c10.tar.bz2
master-187ad058-e2a4217449add9080b6f257ec6b28694dd0e2c10.zip
[ifxmips] move kernel support to 2.6.28.7
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14747 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ifxmips/Makefile')
-rw-r--r--target/linux/ifxmips/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/target/linux/ifxmips/Makefile b/target/linux/ifxmips/Makefile
index fde4d74d8e..27ea078fb8 100644
--- a/target/linux/ifxmips/Makefile
+++ b/target/linux/ifxmips/Makefile
@@ -10,9 +10,8 @@ ARCH:=mips
BOARD:=ifxmips
BOARDNAME:=Infineon Mips
FEATURES:=squashfs jffs2
-SUBTARGETS:=generic nfs
-LINUX_VERSION:=2.6.26.8
-#LINUX_VERSION:=2.6.27.19
+
+LINUX_VERSION:=2.6.28.7
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
@@ -21,4 +20,11 @@ define Target/Description
Build firmware images for Infineon Mips Controllers
endef
+ifeq ($(KERNEL_PATCHVER),2.6.28)
+ define Kernel/Prepare
+ $(call Kernel/Prepare/Default)
+ mv $(LINUX_DIR)/include/asm-mips/* $(LINUX_DIR)/arch/mips/include/asm/
+ endef
+endif
+
$(eval $(call BuildTarget))