aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-12-02 22:23:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-12-02 22:23:22 +0000
commit9da189b6160422c8fe396181ff2d496fa68408b2 (patch)
tree4d911e6fe2fe7e304d340276c06729b33099013c /target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch
parent51a736c6287eb29cc5150f06ce8fdf10b7441a1b (diff)
downloadmaster-187ad058-9da189b6160422c8fe396181ff2d496fa68408b2.tar.gz
master-187ad058-9da189b6160422c8fe396181ff2d496fa68408b2.tar.bz2
master-187ad058-9da189b6160422c8fe396181ff2d496fa68408b2.zip
kernel: add linux 4.4 support
Based on 4.4-rc3. Runtime tested on MIPS. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47701 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..8b0cc2b7b0
--- /dev/null
+++ b/target/linux/generic/patches-4.4/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1654,3 +1654,6 @@ source crypto/asymmetric_keys/Kconfig
+ source certs/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -123,6 +123,8 @@ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) +
+ obj-$(CONFIG_CRYPTO_USER_API_RNG) += algif_rng.o
+ obj-$(CONFIG_CRYPTO_USER_API_AEAD) += algif_aead.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #