aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/720-phy_adm6996.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-12-02 22:23:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-12-02 22:23:22 +0000
commit9da189b6160422c8fe396181ff2d496fa68408b2 (patch)
tree4d911e6fe2fe7e304d340276c06729b33099013c /target/linux/generic/patches-4.4/720-phy_adm6996.patch
parent51a736c6287eb29cc5150f06ce8fdf10b7441a1b (diff)
downloadmaster-187ad058-9da189b6160422c8fe396181ff2d496fa68408b2.tar.gz
master-187ad058-9da189b6160422c8fe396181ff2d496fa68408b2.tar.bz2
master-187ad058-9da189b6160422c8fe396181ff2d496fa68408b2.zip
kernel: add linux 4.4 support
Based on 4.4-rc3. Runtime tested on MIPS. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47701 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.4/720-phy_adm6996.patch')
-rw-r--r--target/linux/generic/patches-4.4/720-phy_adm6996.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/720-phy_adm6996.patch b/target/linux/generic/patches-4.4/720-phy_adm6996.patch
new file mode 100644
index 0000000000..3ee02f1005
--- /dev/null
+++ b/target/linux/generic/patches-4.4/720-phy_adm6996.patch
@@ -0,0 +1,26 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -170,6 +170,13 @@ config MICROCHIP_PHY
+ help
+ Supports the LAN88XX PHYs.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ select SWCONFIG
++ ---help---
++ Currently supports the ADM6996FC and ADM6996M switches.
++ Support for FC is very limited.
++
+ config FIXED_PHY
+ tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -22,6 +22,7 @@ obj-$(CONFIG_BCM7XXX_PHY) += bcm7xxx.o
+ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_BCM_CYGNUS_PHY) += bcm-cygnus.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o