aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-05-10 22:36:56 +0000
committerLuka Perkov <luka@openwrt.org>2016-06-19 19:31:19 +0200
commitf433a43aac4091cf4f71228345500a47ff4812ac (patch)
treed4d4be8cbde22b1b8e854e261b1045319c6e8eb3 /target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
parenta5759c23f3c72ae178eec4c16f3abcfc5fe2206f (diff)
downloadmaster-187ad058-f433a43aac4091cf4f71228345500a47ff4812ac.tar.gz
master-187ad058-f433a43aac4091cf4f71228345500a47ff4812ac.tar.bz2
master-187ad058-f433a43aac4091cf4f71228345500a47ff4812ac.zip
kernel: add workaround to rebuild vdso-o32.so.dbg
Building for octeon fails with 'arch/mips/vdso/vdso-o32.so.dbg' already contains a '.MIPS.abiflags' section if the file already exists from a prior build. Use the same workaround as the one for vdso.so.dbg committed in 9eb155353a5f5137ec85a5b5b0287af63c544710. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49345 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch')
-rw-r--r--target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch15
1 files changed, 13 insertions, 2 deletions
diff --git a/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch b/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
index 3d25e8062b..2a36f2a7a0 100644
--- a/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
+++ b/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
@@ -1,5 +1,7 @@
---- a/arch/mips/vdso/Makefile
-+++ b/arch/mips/vdso/Makefile
+Index: linux-4.4.9/arch/mips/vdso/Makefile
+===================================================================
+--- linux-4.4.9.orig/arch/mips/vdso/Makefile
++++ linux-4.4.9/arch/mips/vdso/Makefile
@@ -75,7 +75,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
$(obj)/vdso.lds: KBUILD_CPPFLAGS := $(native-abi)
@@ -9,3 +11,12 @@
$(call if_changed,vdsold)
$(obj)/vdso-image.c: $(obj)/vdso.so.dbg $(obj)/genvdso FORCE
+@@ -109,7 +109,7 @@ $(obj)/vdso-o32.lds: KBUILD_CPPFLAGS :=
+ $(obj)/vdso-o32.lds: $(src)/vdso.lds.S FORCE
+ $(call if_changed_dep,cpp_lds_S)
+
+-$(obj)/vdso-o32.so.dbg: $(obj)/vdso-o32.lds $(obj-vdso-o32) FORCE
++$(obj)/vdso-o32.so.dbg: $(obj)/vdso-o32.lds $(obj-vdso-o32) $(obj)/genvdso FORCE
+ $(call if_changed,vdsold)
+
+ $(obj)/vdso-o32-image.c: VDSO_NAME := o32