aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-05-10 22:36:39 +0000
committerLuka Perkov <luka@openwrt.org>2016-06-19 19:29:15 +0200
commitef3113b1ef88cf2c14f30aabe6c7840712635300 (patch)
tree18695a2040eea29b512a5919f47a9688091b093a /target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
parent18984188e824fa127b5174c302d00360e4779e7c (diff)
downloadmaster-187ad058-ef3113b1ef88cf2c14f30aabe6c7840712635300.tar.gz
master-187ad058-ef3113b1ef88cf2c14f30aabe6c7840712635300.tar.bz2
master-187ad058-ef3113b1ef88cf2c14f30aabe6c7840712635300.zip
kernel: add a workaround to rebuild vdso.so.dbg after genvdso
Currently the build fails with 'arch/mips/vdso/vdso.so.dbg' already contains a '.MIPS.abiflags' section if the file already exists from a prior build. Add a makefile rule to force the rebuild of vdso.so.dbg if genvdso has has been changed to workaround the failure. Signed-off-by: Jo-Philipp Wich <jo@mein.io> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49334 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch')
-rw-r--r--target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch b/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
new file mode 100644
index 0000000000..3d25e8062b
--- /dev/null
+++ b/target/linux/generic/patches-4.4/207-mips-vdso-dbg-rebuild-after-genvdso.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -75,7 +75,7 @@ $(obj-vdso): KBUILD_AFLAGS := $(aflags-v
+
+ $(obj)/vdso.lds: KBUILD_CPPFLAGS := $(native-abi)
+
+-$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) FORCE
++$(obj)/vdso.so.dbg: $(obj)/vdso.lds $(obj-vdso) $(obj)/genvdso FORCE
+ $(call if_changed,vdsold)
+
+ $(obj)/vdso-image.c: $(obj)/vdso.so.dbg $(obj)/genvdso FORCE