aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4/202-reduce_module_size.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-12-02 22:23:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-12-02 22:23:22 +0000
commit9da189b6160422c8fe396181ff2d496fa68408b2 (patch)
tree4d911e6fe2fe7e304d340276c06729b33099013c /target/linux/generic/patches-4.4/202-reduce_module_size.patch
parent51a736c6287eb29cc5150f06ce8fdf10b7441a1b (diff)
downloadmaster-187ad058-9da189b6160422c8fe396181ff2d496fa68408b2.tar.gz
master-187ad058-9da189b6160422c8fe396181ff2d496fa68408b2.tar.bz2
master-187ad058-9da189b6160422c8fe396181ff2d496fa68408b2.zip
kernel: add linux 4.4 support
Based on 4.4-rc3. Runtime tested on MIPS. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47701 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.4/202-reduce_module_size.patch')
-rw-r--r--target/linux/generic/patches-4.4/202-reduce_module_size.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/202-reduce_module_size.patch b/target/linux/generic/patches-4.4/202-reduce_module_size.patch
new file mode 100644
index 0000000000..cef04d1a43
--- /dev/null
+++ b/target/linux/generic/patches-4.4/202-reduce_module_size.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -398,7 +398,7 @@ KBUILD_CFLAGS_KERNEL :=
+ KBUILD_AFLAGS := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE := -DMODULE
+ KBUILD_CFLAGS_MODULE := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
+
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)