aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/720-phy_adm6996.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-10-11 19:08:08 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-10-11 19:08:08 +0000
commitebc8ef9e87b724526a60e1670834fff4d3bc4698 (patch)
tree190d5518cb8fca114ade113bd2689f1b54852d08 /target/linux/generic/patches-4.3/720-phy_adm6996.patch
parent0ab09e313739ebe5a2d9c3c35354422149760383 (diff)
downloadmaster-187ad058-ebc8ef9e87b724526a60e1670834fff4d3bc4698.tar.gz
master-187ad058-ebc8ef9e87b724526a60e1670834fff4d3bc4698.tar.bz2
master-187ad058-ebc8ef9e87b724526a60e1670834fff4d3bc4698.zip
kernel: generic: add kernel 4.3
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47182 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.3/720-phy_adm6996.patch')
-rw-r--r--target/linux/generic/patches-4.3/720-phy_adm6996.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/720-phy_adm6996.patch b/target/linux/generic/patches-4.3/720-phy_adm6996.patch
new file mode 100644
index 0000000000..1c32b761ad
--- /dev/null
+++ b/target/linux/generic/patches-4.3/720-phy_adm6996.patch
@@ -0,0 +1,26 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -146,6 +146,13 @@ config MICROCHIP_PHY
+ help
+ Supports the LAN88XX PHYs.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ select SWCONFIG
++ ---help---
++ Currently supports the ADM6996FC and ADM6996M switches.
++ Support for FC is very limited.
++
+ config FIXED_PHY
+ tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,7 @@ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_BCM7XXX_PHY) += bcm7xxx.o
+ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o