aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/201-extra_optimization.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-10-11 19:08:08 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-10-11 19:08:08 +0000
commitebc8ef9e87b724526a60e1670834fff4d3bc4698 (patch)
tree190d5518cb8fca114ade113bd2689f1b54852d08 /target/linux/generic/patches-4.3/201-extra_optimization.patch
parent0ab09e313739ebe5a2d9c3c35354422149760383 (diff)
downloadmaster-187ad058-ebc8ef9e87b724526a60e1670834fff4d3bc4698.tar.gz
master-187ad058-ebc8ef9e87b724526a60e1670834fff4d3bc4698.tar.bz2
master-187ad058-ebc8ef9e87b724526a60e1670834fff4d3bc4698.zip
kernel: generic: add kernel 4.3
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47182 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.3/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-4.3/201-extra_optimization.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/201-extra_optimization.patch b/target/linux/generic/patches-4.3/201-extra_optimization.patch
new file mode 100644
index 0000000000..625210de06
--- /dev/null
+++ b/target/linux/generic/patches-4.3/201-extra_optimization.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -607,9 +607,9 @@ include arch/$(SRCARCH)/Makefile
+ KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION) $(call cc-disable-warning,maybe-uninitialized,)
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
+ endif
+
+ # Tell gcc to never replace conditional load with a non-conditional one