aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.1
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-11-13 23:51:31 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-11-13 23:51:31 +0000
commit610c6e99483aa712079dda6b9371fb85c284d97c (patch)
tree7b5e5fb8c99cb21a9a0efe5f19fcf1e3e59d4e84 /target/linux/generic/patches-4.1
parente6a8125fa4dad40b6042bfa544bb85b0e59cdad4 (diff)
downloadmaster-187ad058-610c6e99483aa712079dda6b9371fb85c284d97c.tar.gz
master-187ad058-610c6e99483aa712079dda6b9371fb85c284d97c.tar.bz2
master-187ad058-610c6e99483aa712079dda6b9371fb85c284d97c.zip
kernel: take bcm47xx_nvram.h from kernel and not backports
compat-wireless/backports now contains a bcm47xx_nvram.h file to backport some of the functions in it which are used by the bcmfmac driver. This file just checks for the kernel versions and provide an empty implementations on older kernel versions. This is OK on most systems, but on bcm47xx / bcm53xx systems we want to call the real functions here. This commit removes the file from backports in our build process like we do it with the bcma and ssb header files. Instead we add a recent version into our kernel so all code uses only one header file. On bcm47xx / bcm53xx the real implementations of this code will be used. Reported-by: Hante Meuleman <meuleman@broadcom.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47467 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.1')
-rw-r--r--target/linux/generic/patches-4.1/030-backport_bcm47xx_nvram.patch37
-rw-r--r--target/linux/generic/patches-4.1/133-MIPS-UAPI-Ignore-__arch_swab-16-32-64-when-using-MIP.patch7
-rw-r--r--target/linux/generic/patches-4.1/222-perf-build-Do-not-fail-on-missing-Build-file.patch10
3 files changed, 38 insertions, 16 deletions
diff --git a/target/linux/generic/patches-4.1/030-backport_bcm47xx_nvram.patch b/target/linux/generic/patches-4.1/030-backport_bcm47xx_nvram.patch
new file mode 100644
index 0000000000..c20f05e079
--- /dev/null
+++ b/target/linux/generic/patches-4.1/030-backport_bcm47xx_nvram.patch
@@ -0,0 +1,37 @@
+--- a/include/linux/bcm47xx_nvram.h
++++ b/include/linux/bcm47xx_nvram.h
+@@ -10,11 +10,17 @@
+
+ #include <linux/types.h>
+ #include <linux/kernel.h>
++#include <linux/vmalloc.h>
+
+-#ifdef CONFIG_BCM47XX
++#ifdef CONFIG_BCM47XX_NVRAM
+ int bcm47xx_nvram_init_from_mem(u32 base, u32 lim);
+ int bcm47xx_nvram_getenv(const char *name, char *val, size_t val_len);
+ int bcm47xx_nvram_gpio_pin(const char *name);
++char *bcm47xx_nvram_get_contents(size_t *val_len);
++static inline void bcm47xx_nvram_release_contents(char *nvram)
++{
++ vfree(nvram);
++};
+ #else
+ static inline int bcm47xx_nvram_init_from_mem(u32 base, u32 lim)
+ {
+@@ -29,6 +35,15 @@ static inline int bcm47xx_nvram_gpio_pin
+ {
+ return -ENOTSUPP;
+ };
++
++static inline char *bcm47xx_nvram_get_contents(size_t *val_len)
++{
++ return NULL;
++};
++
++static inline void bcm47xx_nvram_release_contents(char *nvram)
++{
++};
+ #endif
+
+ #endif /* __BCM47XX_NVRAM_H */
diff --git a/target/linux/generic/patches-4.1/133-MIPS-UAPI-Ignore-__arch_swab-16-32-64-when-using-MIP.patch b/target/linux/generic/patches-4.1/133-MIPS-UAPI-Ignore-__arch_swab-16-32-64-when-using-MIP.patch
index d8f25ac1fd..ebbe1bbaee 100644
--- a/target/linux/generic/patches-4.1/133-MIPS-UAPI-Ignore-__arch_swab-16-32-64-when-using-MIP.patch
+++ b/target/linux/generic/patches-4.1/133-MIPS-UAPI-Ignore-__arch_swab-16-32-64-when-using-MIP.patch
@@ -30,8 +30,6 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
arch/mips/include/uapi/asm/swab.h | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
-diff --git a/arch/mips/include/uapi/asm/swab.h b/arch/mips/include/uapi/asm/swab.h
-index 8f2d184..23cd9b1 100644
--- a/arch/mips/include/uapi/asm/swab.h
+++ b/arch/mips/include/uapi/asm/swab.h
@@ -13,8 +13,9 @@
@@ -46,13 +44,10 @@ index 8f2d184..23cd9b1 100644
static inline __attribute_const__ __u16 __arch_swab16(__u16 x)
{
-@@ -65,5 +66,5 @@ static inline __attribute_const__ __u64 __arch_swab64(__u64 x)
+@@ -65,5 +66,5 @@ static inline __attribute_const__ __u64
}
#define __arch_swab64 __arch_swab64
#endif /* __mips64 */
-#endif /* MIPS R2 or newer or Loongson 3A */
+#endif /* (not __mips16) and (MIPS R2 or newer or Loongson 3A) */
#endif /* _ASM_SWAB_H */
---
-1.7.10.4
-
diff --git a/target/linux/generic/patches-4.1/222-perf-build-Do-not-fail-on-missing-Build-file.patch b/target/linux/generic/patches-4.1/222-perf-build-Do-not-fail-on-missing-Build-file.patch
index 3fb2df6ef1..2026e4da8d 100644
--- a/target/linux/generic/patches-4.1/222-perf-build-Do-not-fail-on-missing-Build-file.patch
+++ b/target/linux/generic/patches-4.1/222-perf-build-Do-not-fail-on-missing-Build-file.patch
@@ -29,8 +29,6 @@ Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
3 files changed, 4 insertions(+), 1 deletion(-)
create mode 100644 tools/build/tests/ex/empty2/README
-diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
-index 10df572..69c35cf 100644
--- a/tools/build/Makefile.build
+++ b/tools/build/Makefile.build
@@ -37,7 +37,7 @@ subdir-obj-y :=
@@ -42,8 +40,6 @@ index 10df572..69c35cf 100644
quiet_cmd_flex = FLEX $@
quiet_cmd_bison = BISON $@
-diff --git a/tools/build/tests/ex/Build b/tools/build/tests/ex/Build
-index 0e6c3e6..70d8762 100644
--- a/tools/build/tests/ex/Build
+++ b/tools/build/tests/ex/Build
@@ -2,6 +2,7 @@ ex-y += ex.o
@@ -54,14 +50,8 @@ index 0e6c3e6..70d8762 100644
libex-y += c.o
libex-y += d.o
-diff --git a/tools/build/tests/ex/empty2/README b/tools/build/tests/ex/empty2/README
-new file mode 100644
-index 0000000..2107cc5
--- /dev/null
+++ b/tools/build/tests/ex/empty2/README
@@ -0,0 +1,2 @@
+This directory is left intentionally without Build file
+to test proper nesting into Build-less directories.
---
-2.1.4
-