aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.1/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
committerJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
commitdc18617098592901d24daa1fce6734e9c62cbef1 (patch)
treece824259896e9866aa6d76e388ce9272a7ba24a1 /target/linux/generic/patches-4.1/940-ocf_kbuild_integration.patch
parent148eac2b3134cc8e1eeaeea95c385a130b953335 (diff)
downloadmaster-187ad058-dc18617098592901d24daa1fce6734e9c62cbef1.tar.gz
master-187ad058-dc18617098592901d24daa1fce6734e9c62cbef1.tar.bz2
master-187ad058-dc18617098592901d24daa1fce6734e9c62cbef1.zip
generic: add linux 4.1 support
Boot tested: http://pastebin.com/L6aAb9xj Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: update to 4.1 final add patches added since submission delete patches applied in later rcs restore commit messages in 220-gc-sections and 304-mips_disable_fpu fix 050-backport_netfilter_rtcache to match new API update inlined dma ops with upstream changes add missing config symbols enabled CONFIG_MULTIUSER update kmod defintions for 4.1 ] Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46112 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.1/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-4.1/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.1/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-4.1/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..a50cd9cfd1
--- /dev/null
+++ b/target/linux/generic/patches-4.1/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1526,3 +1526,6 @@ source "drivers/crypto/Kconfig"
+ source crypto/asymmetric_keys/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -103,6 +103,8 @@ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) +
+ obj-$(CONFIG_CRYPTO_USER_API_RNG) += algif_rng.o
+ obj-$(CONFIG_CRYPTO_USER_API_AEAD) += algif_aead.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #