aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.1/903-debloat_direct_io.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
committerJonas Gorski <jogo@openwrt.org>2015-06-22 12:27:59 +0000
commitdc18617098592901d24daa1fce6734e9c62cbef1 (patch)
treece824259896e9866aa6d76e388ce9272a7ba24a1 /target/linux/generic/patches-4.1/903-debloat_direct_io.patch
parent148eac2b3134cc8e1eeaeea95c385a130b953335 (diff)
downloadmaster-187ad058-dc18617098592901d24daa1fce6734e9c62cbef1.tar.gz
master-187ad058-dc18617098592901d24daa1fce6734e9c62cbef1.tar.bz2
master-187ad058-dc18617098592901d24daa1fce6734e9c62cbef1.zip
generic: add linux 4.1 support
Boot tested: http://pastebin.com/L6aAb9xj Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: update to 4.1 final add patches added since submission delete patches applied in later rcs restore commit messages in 220-gc-sections and 304-mips_disable_fpu fix 050-backport_netfilter_rtcache to match new API update inlined dma ops with upstream changes add missing config symbols enabled CONFIG_MULTIUSER update kmod defintions for 4.1 ] Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46112 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.1/903-debloat_direct_io.patch')
-rw-r--r--target/linux/generic/patches-4.1/903-debloat_direct_io.patch80
1 files changed, 80 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.1/903-debloat_direct_io.patch b/target/linux/generic/patches-4.1/903-debloat_direct_io.patch
new file mode 100644
index 0000000000..b428a0cffc
--- /dev/null
+++ b/target/linux/generic/patches-4.1/903-debloat_direct_io.patch
@@ -0,0 +1,80 @@
+--- a/fs/Kconfig
++++ b/fs/Kconfig
+@@ -71,6 +71,11 @@ config FILE_LOCKING
+ for filesystems like NFS and for the flock() system
+ call. Disabling this option saves about 11k.
+
++config DIRECT_IO
++ bool "Enable O_DIRECT support" if EXPERT
++ depends on BLOCK
++ default y
++
+ source "fs/notify/Kconfig"
+
+ source "fs/quota/Kconfig"
+--- a/fs/Makefile
++++ b/fs/Makefile
+@@ -14,7 +14,8 @@ obj-y := open.o read_write.o file_table.
+ stack.o fs_struct.o statfs.o fs_pin.o nsfs.o
+
+ ifeq ($(CONFIG_BLOCK),y)
+-obj-y += buffer.o block_dev.o direct-io.o mpage.o
++obj-y += buffer.o block_dev.o mpage.o
++obj-$(CONFIG_DIRECT_IO) += direct-io.o
+ else
+ obj-y += no-block.o
+ endif
+--- a/include/linux/fs.h
++++ b/include/linux/fs.h
+@@ -2649,6 +2649,7 @@ enum {
+ DIO_SKIP_DIO_COUNT = 0x08,
+ };
+
++#ifdef CONFIG_DIRECT_IO
+ void dio_end_io(struct bio *bio, int error);
+
+ ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
+@@ -2656,6 +2657,18 @@ ssize_t __blockdev_direct_IO(struct kioc
+ loff_t offset, get_block_t get_block,
+ dio_iodone_t end_io, dio_submit_t submit_io,
+ int flags);
++#else
++static inline void dio_end_io(struct bio *bio, int error)
++{
++}
++static inline ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
++ struct block_device *bdev, struct iov_iter *iter, loff_t offset,
++ get_block_t get_block, dio_iodone_t end_io,
++ dio_submit_t submit_io, int flags)
++{
++ return -EOPNOTSUPP;
++}
++#endif
+
+ static inline ssize_t blockdev_direct_IO(struct kiocb *iocb,
+ struct inode *inode,
+--- a/fs/fcntl.c
++++ b/fs/fcntl.c
+@@ -52,8 +52,10 @@ static int setfl(int fd, struct file * f
+ arg |= O_NONBLOCK;
+
+ if (arg & O_DIRECT) {
++#ifdef CONFIG_DIRECT_IO
+ if (!filp->f_mapping || !filp->f_mapping->a_ops ||
+ !filp->f_mapping->a_ops->direct_IO)
++#endif
+ return -EINVAL;
+ }
+
+--- a/fs/open.c
++++ b/fs/open.c
+@@ -671,7 +671,9 @@ int open_check_o_direct(struct file *f)
+ {
+ /* NB: we're sure to have correct a_ops only after f_op->open */
+ if (f->f_flags & O_DIRECT) {
++#ifdef CONFIG_DIRECT_IO
+ if (!f->f_mapping->a_ops || !f->f_mapping->a_ops->direct_IO)
++#endif
+ return -EINVAL;
+ }
+ return 0;