aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.0/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-07 16:22:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-07 16:22:08 +0000
commit0d3e8b9b52182686843532790f7376720f8d2328 (patch)
treeea6d94b39c06cee91cd442f56076f32b21196c52 /target/linux/generic/patches-4.0/832-ledtrig_usbdev.patch
parent0b452f378bf397fe3825a7fa5b77354e8f64100a (diff)
downloadmaster-187ad058-0d3e8b9b52182686843532790f7376720f8d2328.tar.gz
master-187ad058-0d3e8b9b52182686843532790f7376720f8d2328.tar.bz2
master-187ad058-0d3e8b9b52182686843532790f7376720f8d2328.zip
kernel: remove linux 4.0 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47412 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.0/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-4.0/832-ledtrig_usbdev.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/generic/patches-4.0/832-ledtrig_usbdev.patch b/target/linux/generic/patches-4.0/832-ledtrig_usbdev.patch
deleted file mode 100644
index 25593fd818..0000000000
--- a/target/linux/generic/patches-4.0/832-ledtrig_usbdev.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/leds/trigger/Kconfig
-+++ b/drivers/leds/trigger/Kconfig
-@@ -119,4 +119,11 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
-
-+config LEDS_TRIGGER_USBDEV
-+ tristate "LED USB device Trigger"
-+ depends on USB && LEDS_TRIGGERS
-+ help
-+ This allows LEDs to be controlled by the presence/activity of
-+ an USB device. If unsure, say N.
-+
- endif # LEDS_TRIGGERS
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -66,3 +66,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
- obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
- obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
-+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
---- a/drivers/leds/ledtrig-usbdev.c
-+++ b/drivers/leds/ledtrig-usbdev.c
-@@ -24,7 +24,6 @@
- #include <linux/list.h>
- #include <linux/spinlock.h>
- #include <linux/device.h>
--#include <linux/sysdev.h>
- #include <linux/timer.h>
- #include <linux/ctype.h>
- #include <linux/slab.h>