aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.9/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
commitddc8718f7f4ef9723e026efac811d3338e6bcddb (patch)
tree08d6be7813310be182259388518215a17afcc18c /target/linux/generic/patches-3.9/832-ledtrig_usbdev.patch
parent6cb1f067dc42c4bffa8862448167486333d0227e (diff)
downloadmaster-187ad058-ddc8718f7f4ef9723e026efac811d3338e6bcddb.tar.gz
master-187ad058-ddc8718f7f4ef9723e026efac811d3338e6bcddb.tar.bz2
master-187ad058-ddc8718f7f4ef9723e026efac811d3338e6bcddb.zip
kernel: add support for 3.9-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36008 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.9/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-3.9/832-ledtrig_usbdev.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.9/832-ledtrig_usbdev.patch b/target/linux/generic/patches-3.9/832-ledtrig_usbdev.patch
new file mode 100644
index 0000000000..d167c108a9
--- /dev/null
+++ b/target/linux/generic/patches-3.9/832-ledtrig_usbdev.patch
@@ -0,0 +1,31 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -582,4 +582,11 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_USBDEV
++ tristate "LED USB device Trigger"
++ depends on USB && LEDS_TRIGGERS
++ help
++ This allows LEDs to be controlled by the presence/activity of
++ an USB device. If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -68,3 +68,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
+ obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) += ledtrig-transient.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+--- a/drivers/leds/ledtrig-usbdev.c
++++ b/drivers/leds/ledtrig-usbdev.c
+@@ -24,7 +24,6 @@
+ #include <linux/list.h>
+ #include <linux/spinlock.h>
+ #include <linux/device.h>
+-#include <linux/sysdev.h>
+ #include <linux/timer.h>
+ #include <linux/ctype.h>
+ #include <linux/slab.h>