aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.9/730-phy_b53.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-03-14 14:45:56 +0000
commitddc8718f7f4ef9723e026efac811d3338e6bcddb (patch)
tree08d6be7813310be182259388518215a17afcc18c /target/linux/generic/patches-3.9/730-phy_b53.patch
parent6cb1f067dc42c4bffa8862448167486333d0227e (diff)
downloadmaster-187ad058-ddc8718f7f4ef9723e026efac811d3338e6bcddb.tar.gz
master-187ad058-ddc8718f7f4ef9723e026efac811d3338e6bcddb.tar.bz2
master-187ad058-ddc8718f7f4ef9723e026efac811d3338e6bcddb.zip
kernel: add support for 3.9-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36008 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.9/730-phy_b53.patch')
-rw-r--r--target/linux/generic/patches-3.9/730-phy_b53.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.9/730-phy_b53.patch b/target/linux/generic/patches-3.9/730-phy_b53.patch
new file mode 100644
index 0000000000..c3b9de5fe0
--- /dev/null
+++ b/target/linux/generic/patches-3.9/730-phy_b53.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -251,6 +251,8 @@ config RTL8367B_PHY
+
+ endif # RTL8366_SMI
+
++source "drivers/net/phy/b53/Kconfig"
++
+ endif # PHYLIB
+
+ config MICREL_KS8995MA
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_PSB6970_PHY) += psb6970.o
++obj-$(CONFIG_B53) += b53/
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o