aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.8
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-01-23 10:12:33 +0000
committerJonas Gorski <jogo@openwrt.org>2013-01-23 10:12:33 +0000
commit793f269e52d31fdbfc83d319a6c7598673f9722b (patch)
tree66097161c6a6f9962a5f8156a61c2ca6a1261c6d /target/linux/generic/patches-3.8
parent4257876e46d9d4329770e72e9aa16599597878fa (diff)
downloadmaster-187ad058-793f269e52d31fdbfc83d319a6c7598673f9722b.tar.gz
master-187ad058-793f269e52d31fdbfc83d319a6c7598673f9722b.tar.bz2
master-187ad058-793f269e52d31fdbfc83d319a6c7598673f9722b.zip
generic: add b53 swconfig switch driver
Add swconfig switch driver for Broadcom BCM53XX switch chips. Supports switches connected through MDIO, SPI or memory mapped registers, and supports BCM5325, BCM539x, BCM531x5 and the BCM63XX internal switch chips. Tested are BCM5325 trough MDIO, BCM53115 through SPI, and BCM6328. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35305 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.8')
-rw-r--r--target/linux/generic/patches-3.8/730-phy_b53.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.8/730-phy_b53.patch b/target/linux/generic/patches-3.8/730-phy_b53.patch
new file mode 100644
index 0000000000..75972e58d6
--- /dev/null
+++ b/target/linux/generic/patches-3.8/730-phy_b53.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -252,6 +252,8 @@ config RTL8367B_PHY
+
+ endif # RTL8366_SMI
+
++source "drivers/net/phy/b53/Kconfig"
++
+ endif # PHYLIB
+
+ config MICREL_KS8995MA
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_PSB6970_PHY) += psb6970.o
++obj-$(CONFIG_B53) += b53/
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o