aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-05 13:33:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-05 13:33:44 +0000
commitbea9349879215a146978a6753a7bd1c5a9199a7d (patch)
tree19976e61784f94c7937ce2703d6d1e8b83a23584 /target/linux/generic/patches-3.7
parent3dad88cbb5f0f786b75babce487b4b528d872d1d (diff)
downloadmaster-187ad058-bea9349879215a146978a6753a7bd1c5a9199a7d.tar.gz
master-187ad058-bea9349879215a146978a6753a7bd1c5a9199a7d.tar.bz2
master-187ad058-bea9349879215a146978a6753a7bd1c5a9199a7d.zip
kernel: port the regmap fix to 3.6 (#12749), refresh patches for other versions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35016 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.7')
-rw-r--r--target/linux/generic/patches-3.7/259-regmap_dynamic.patch20
1 files changed, 7 insertions, 13 deletions
diff --git a/target/linux/generic/patches-3.7/259-regmap_dynamic.patch b/target/linux/generic/patches-3.7/259-regmap_dynamic.patch
index df75b4ee21..83d53d97d4 100644
--- a/target/linux/generic/patches-3.7/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-3.7/259-regmap_dynamic.patch
@@ -1,7 +1,5 @@
-Index: linux-3.7.1/drivers/base/regmap/Kconfig
-===================================================================
---- linux-3.7.1.orig/drivers/base/regmap/Kconfig 2012-12-17 20:14:54.000000000 +0100
-+++ linux-3.7.1/drivers/base/regmap/Kconfig 2013-01-05 01:07:25.712704474 +0100
+--- a/drivers/base/regmap/Kconfig
++++ b/drivers/base/regmap/Kconfig
@@ -3,20 +3,23 @@
# subsystems should select the appropriate symbols.
@@ -30,11 +28,9 @@ Index: linux-3.7.1/drivers/base/regmap/Kconfig
config REGMAP_IRQ
+ select REGMAP
bool
-Index: linux-3.7.1/include/linux/regmap.h
-===================================================================
---- linux-3.7.1.orig/include/linux/regmap.h 2012-12-17 20:14:54.000000000 +0100
-+++ linux-3.7.1/include/linux/regmap.h 2013-01-05 01:03:32.012694484 +0100
-@@ -43,7 +43,7 @@
+--- a/include/linux/regmap.h
++++ b/include/linux/regmap.h
+@@ -43,7 +43,7 @@ struct reg_default {
unsigned int def;
};
@@ -43,10 +39,8 @@ Index: linux-3.7.1/include/linux/regmap.h
enum regmap_endian {
/* Unspecified -> 0 -> Backwards compatible default */
-Index: linux-3.7.1/drivers/base/regmap/Makefile
-===================================================================
---- linux-3.7.1.orig/drivers/base/regmap/Makefile 2012-12-17 20:14:54.000000000 +0100
-+++ linux-3.7.1/drivers/base/regmap/Makefile 2013-01-05 01:08:16.592706650 +0100
+--- a/drivers/base/regmap/Makefile
++++ b/drivers/base/regmap/Makefile
@@ -1,6 +1,8 @@
-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o