aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7/201-extra_optimization.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-20 07:37:27 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-20 07:37:27 +0000
commit2d33c40879046906afeb3bb4eaefbd4d14c9b503 (patch)
tree5f4a31a2b4ea39aab41f28580fbf13fc0f7976f8 /target/linux/generic/patches-3.7/201-extra_optimization.patch
parent5dcd68e0131317e8ffb7980f7c1dd49f34170cce (diff)
downloadmaster-187ad058-2d33c40879046906afeb3bb4eaefbd4d14c9b503.tar.gz
master-187ad058-2d33c40879046906afeb3bb4eaefbd4d14c9b503.tar.bz2
master-187ad058-2d33c40879046906afeb3bb4eaefbd4d14c9b503.zip
linux: remove 3.7 support
It is not used by any target. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37469 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.7/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.7/201-extra_optimization.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/generic/patches-3.7/201-extra_optimization.patch b/target/linux/generic/patches-3.7/201-extra_optimization.patch
deleted file mode 100644
index d94d2cf3a8..0000000000
--- a/target/linux/generic/patches-3.7/201-extra_optimization.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -570,9 +570,9 @@ endif # $(dot-config)
- all: vmlinux
-
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
--KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-caller-saves
- else
--KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
- endif
-
- include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -645,6 +645,9 @@ endif
- NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
- CHECKFLAGS += $(NOSTDINC_FLAGS)
-
-+# improve gcc optimization
-+CFLAGS += $(call cc-option,-funit-at-a-time,)
-+
- # warn about C99 declaration after statement
- KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
-