aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.6/862-gpio_spi_driver.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-24 13:05:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-24 13:05:22 +0000
commitdcde44e37ed89b02bf98c89c9d20eb7097e21707 (patch)
treeb152afa6fd38537133c7a67e6aeff8476342d5a0 /target/linux/generic/patches-3.6/862-gpio_spi_driver.patch
parent59d0f03c9af97f38ddb4b99d9a86fa845e1fe170 (diff)
downloadmaster-187ad058-dcde44e37ed89b02bf98c89c9d20eb7097e21707.tar.gz
master-187ad058-dcde44e37ed89b02bf98c89c9d20eb7097e21707.tar.bz2
master-187ad058-dcde44e37ed89b02bf98c89c9d20eb7097e21707.zip
[kernel] make all 3.6 patches apply and build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33911 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.6/862-gpio_spi_driver.patch')
-rw-r--r--target/linux/generic/patches-3.6/862-gpio_spi_driver.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/generic/patches-3.6/862-gpio_spi_driver.patch b/target/linux/generic/patches-3.6/862-gpio_spi_driver.patch
index 6cbea32a31..16d80d9587 100644
--- a/target/linux/generic/patches-3.6/862-gpio_spi_driver.patch
+++ b/target/linux/generic/patches-3.6/862-gpio_spi_driver.patch
@@ -345,7 +345,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
+MODULE_LICENSE("GPL v2");
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
-@@ -154,6 +154,15 @@ config SPI_GPIO
+@@ -169,6 +169,15 @@ config SPI_GPIO
GPIO operations, you should be able to leverage that for better
speed with a custom version of this driver; see the source code.
@@ -363,7 +363,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
depends on ARCH_MXC
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
-@@ -29,6 +29,7 @@ obj-$(CONFIG_SPI_FSL_LIB) += spi-fsl-li
+@@ -31,6 +31,7 @@ obj-$(CONFIG_SPI_FSL_LIB) += spi-fsl-li
obj-$(CONFIG_SPI_FSL_ESPI) += spi-fsl-espi.o
obj-$(CONFIG_SPI_FSL_SPI) += spi-fsl-spi.o
obj-$(CONFIG_SPI_GPIO) += spi-gpio.o