aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.6/305-mips_module_reloc.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-12-28 19:17:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-12-28 19:17:19 +0000
commitc28528a91301949a64b96317ae095da6cf2c4b2b (patch)
treec36a6336a7c6810b0d1c3a0d1c7163f015824c8d /target/linux/generic/patches-3.6/305-mips_module_reloc.patch
parent7bd61ec3c94840a447dd4a221381b8af854cbbf9 (diff)
downloadmaster-187ad058-c28528a91301949a64b96317ae095da6cf2c4b2b.tar.gz
master-187ad058-c28528a91301949a64b96317ae095da6cf2c4b2b.tar.bz2
master-187ad058-c28528a91301949a64b96317ae095da6cf2c4b2b.zip
mips: use -mno-branch-likely for kernel and userspace, saves ~11k kernel size after lzma and ~12k squashfs size in the default configuration
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34909 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.6/305-mips_module_reloc.patch')
-rw-r--r--target/linux/generic/patches-3.6/305-mips_module_reloc.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/generic/patches-3.6/305-mips_module_reloc.patch b/target/linux/generic/patches-3.6/305-mips_module_reloc.patch
index fea4a00129..a2738dca7e 100644
--- a/target/linux/generic/patches-3.6/305-mips_module_reloc.patch
+++ b/target/linux/generic/patches-3.6/305-mips_module_reloc.patch
@@ -1,7 +1,7 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -90,8 +90,8 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
- cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
+ cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
cflags-y += -msoft-float
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
-KBUILD_AFLAGS_MODULE += -mlong-calls