aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-02-02 08:23:54 +0000
committerJonas Gorski <jogo@openwrt.org>2012-02-02 08:23:54 +0000
commitafbffe9fcd7261cfcf8ff462ad81aea553b2241a (patch)
tree520b2ce27d8ce9fca04ceff102605b733c4e27d2 /target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch
parent47f5be9659a16031b9ce946b437b5af71cc004a8 (diff)
downloadmaster-187ad058-afbffe9fcd7261cfcf8ff462ad81aea553b2241a.tar.gz
master-187ad058-afbffe9fcd7261cfcf8ff462ad81aea553b2241a.tar.bz2
master-187ad058-afbffe9fcd7261cfcf8ff462ad81aea553b2241a.zip
kernel: add preliminary support for linux 3.3
Based on 3.3-rc2 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29986 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..55a2bed030
--- /dev/null
+++ b/target/linux/generic/patches-3.3/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -961,3 +961,6 @@ config CRYPTO_USER_API_SKCIPHER
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -91,6 +91,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #