aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3/724-phy_ar8216.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-02-02 08:23:54 +0000
committerJonas Gorski <jogo@openwrt.org>2012-02-02 08:23:54 +0000
commitafbffe9fcd7261cfcf8ff462ad81aea553b2241a (patch)
tree520b2ce27d8ce9fca04ceff102605b733c4e27d2 /target/linux/generic/patches-3.3/724-phy_ar8216.patch
parent47f5be9659a16031b9ce946b437b5af71cc004a8 (diff)
downloadmaster-187ad058-afbffe9fcd7261cfcf8ff462ad81aea553b2241a.tar.gz
master-187ad058-afbffe9fcd7261cfcf8ff462ad81aea553b2241a.tar.bz2
master-187ad058-afbffe9fcd7261cfcf8ff462ad81aea553b2241a.zip
kernel: add preliminary support for linux 3.3
Based on 3.3-rc2 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29986 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.3/724-phy_ar8216.patch')
-rw-r--r--target/linux/generic/patches-3.3/724-phy_ar8216.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.3/724-phy_ar8216.patch b/target/linux/generic/patches-3.3/724-phy_ar8216.patch
new file mode 100644
index 0000000000..7a51dccee8
--- /dev/null
+++ b/target/linux/generic/patches-3.3/724-phy_ar8216.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -116,6 +116,10 @@ config IP17XX_PHY
+ tristate "Driver for IC+ IP17xx switches"
+ select SWCONFIG
+
++config AR8216_PHY
++ tristate "Driver for Atheros AR8216 switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
++obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o